SuiteCRM email campaign not sending

My suitecrm is not sending email campaign. When i sent them from the queue they dont get sent. i can test send the outgoing email configuration successfully.

I have installed it on centos via plesk. I am using 7.5
I have tried different Target List type (Test and Default) but none.
When i click send queued campaign emails from the queue email in the admin it reloads the page and the queued emails are still there.
I can successfully test send the outgoing email configuration.

Any help will be appreciated

I am having a similar issue. I recently did a fresh install of SuiteCRM 7.6, since I have upgraded to 7.6.1.
The older version on the same server had no issues sending the campaign emails.
All test emails get sent successfully.

I am now having issues sending the campaign emails, the log shows the following errors:

Wed May 4 21:28:20 2016 [20965][6f86262a-c8fe-6c61-d427-5559058ee03d][FATAL] Error acquiring lock for the emailman entry, skipping email delivery. lock status=-1 Array
[date_entered] => 2016-05-04 16:51:46
[date_modified] =>
[user_id] => 6f86262a-c8fe-6c61-d427-5559058ee03d
[id] => 2639
[campaign_id] => 2d1ede7a-ee42-a196-efcf-56833a577dd7
[marketing_id] => c101ca8d-ddaa-50f6-72a1-5726c4ea7780
[list_id] => 22c235b8-cf6e-4cea-175b-5566452c6e4a
[send_date_time] => 2016-05-01 04:00:00
[modified_user_id] =>
[in_queue] => 0
[in_queue_date] =>
[send_attempts] => 0
[deleted] => 0
[related_id] => 9c13c606-4585-276f-e888-572782d5826a
[related_type] => Contacts

Any help would be appreciated.


Found the solution. Looks like this is a bug in 7.6 & 7.6.1 with musqli autocommits.

After manually updating the 2 files with the changes, it is working and the campaign emails are going out.
Thanks to dodexahedron…

is your problem solved

Yes, my problem was resolved. Not sure about damilola.

And it looks like the fix is included in 7.6.2; but I haven’t had a chance to upgrade yet.