SuiteCRM Analytics - Solution, Bug Tracker, Feedback!

You can do either. Assuming your SuiteCRM Server has OpenJDK8 installed then SuiteCRM Analytics will work.

It is worth pointing out however that IF you install SuiteCRM Analytics on the same server as your SuiteCRM web application then you might run into performance issues when people try to run big queries from SuiteCRM Analytics. It might be better practise to place your copy of SuiteCRM Analytics on a whole new server so your analysts can run reporting queries without impacting your installation of SuiteCRM where people will be adding, editing and deleting records.

One other thing to consider is that IF SuiteCRM Analytics is installed on a separate server then it will be pulling data across the network from SuiteCRM which could be slightly slower than if they were both installed on the same machine. You need to weigh up the pros and cons as there is not simple answer. A second server or SuiteCRM Analytics will no doubt also cost more money than a single server.

I hope this helps a little and if you have feedback on the documentation then please let me know as its only based on installation at the moment.


1 Like

One other thing I forgot to mention! I should add to the documentation they recommended hardware required to run SuiteCRM Analytics. Unlike SuiteCRM which does not require much ram etc, SuiteCRM Analytics can benefit from a more powerful machine.

This is simply because SuiteCRM queries are usually only bringing back small amount of data. SuiteCRM Analytics can pull back much more data for aggregation.

I would recommend a minimum of 4gb ram for SuiteCRM analytics. The VMs i work on here I give them around 8gbs ram so that i get good performance

1 Like

Hi everybody!

I’ve been trying to install and run SuiteCRM Analytics. The installation process seemed to be successful. But when I ran I get a bunch of errors in Catalina logs and a 404 http error when trying to access the web interface.

Here’s the log file

Could anybody help me, please?
Thank you very much

Hey there,

Its difficult to tell looking at the log. Could you try stopping all Java processes and deleting the tomcat/logs/catalina.out log for me then try to start the server fresh again? If it fails to boot send me the catalina.out log file so I can see what happening from a fresh boot.

Please make sure that all java processes associated with the suitecrm server have stopped before you do this! Either run the stop bash script or kill the java processes before you try to boot again.


Thank you very much, @ivyis for your interest.

Here’s the log file after stopping all java processes and rebooting:

Sorry guys… reviewing the requirements I realized I had both OpenJDK 8 and 11 installed. I just removed version 11 and it worked!

Thank you anyway.

Ahhh thats an easy mistake to make. Good job!

1 Like

Tell me that’s an easy mistake, too!

Greetings. I’m trying to get SuiteCRM data analytics installed in my server and i’m failing everytime.

I’ve checked and i have wget installed and tomcat running.
I also java SDK. Whenever i check it (By using java -version) i get this

openjdk version “1.8.0_242”
OpenJDK Runtime Environment (build 1.8.0_242-8u242-b08-0ubuntu3~18.04-? b08)
OpenJDK 64-Bit Server VM (build 25.242-b08, mixed mode)

Thing is, whenever i run script i get this error:

Checking database Connections…
./ line 10: ./ No such file or directory

We could not establish a connection to the SuiteCRM database!
Please check the JDBC connection properties and run setup again.

It seems a bad configuration but i properly set based in my database configuration which it’s perfectly running with suiteCRM itself and other projects hosted in my server.

Any ideas? Please help. Thank you

Hi there i installed the data analytics, but when i try to get information from the database of suite crm, i get Error processing component or error parsing parameter information. Does anybody knows how to solve this.
Waiting for reply


Can you send us the tomcat/logs/catalina.out output when you run a dashboard?

Hi there here is the log file , thanks in advanced

The last error I can see is this: Table ‘webcrm.D_CAMPAIGNS’ doesn’t exist

It looks like your installation is pointing to a database with the name webcrm and this database does not exist. Are you sure that this database exists and its populated with the correct tables. You need to run SuiteCRM Data Integration to create the database / tables

Hi thanks for your quick reply, i follow this guide , the database webcrm is empty, how can i populate the database, do you have any other guide?

SuiteCRM Analytics relies on the other project caled SuiteCRM Data Integration. Please install that

Hi there i installed suitecrm data integration, put the data on install properties, run the connection to the database successful, populating with success to the other database, witch right now is not empty. i run and then . Then i went to analytics, i can see custom oportunities that i made but i can not retrieve any data. I tried other report like agent opportunity performance and shows

Agent Opportunity Performance Report
Opportunity Created Period: All Periods
Opportunity Lead Source: All Opportunity Lead Sources
Opportunity Sales Stage: All Opportunity Sales Stages
Opportunity Type: All Opportunity Types
No Data Available for Selected Parameters
Report Run By: admin
Report Run Date: 2021-05-04

Can someone help to get this working properly.


Anybody can help here?
I really need this working right.



You state that you have run ‘’. There is an option during the setup process to install demo data. Did you do this?

The ‘No Data Available for Selected Parameters’ should not appear on any report if the demo data was installed.

Demo Data wont populate any custom tables made by you.

Hi There thanks for your reply, the first time i didnt install any demo data, the second time i cleaned the database and installed the demo data , and the problem persists, the second time is giving another error on agents aportunity report " Failed to process the report. Failed to fire report event for sub-layout-process. Could not initialize class sun.awt.x11GraphicsEnvironment. Is there any walktrought to setup this correctly.

thanks in advanced

Sounds like things are overlapping each other from multiple failed setups.

Suggest you drop and recreate the database and delete all the files. Unzip the application and and start fresh following the guidance here…