SuiteCRM 8.5 - Stuck at legal terms screen - Installation wizard

I’m making an install to check out 8.5 and set everything up, but I cannot get past the terms screen:
image

The Next button is grayed out and refuses to work. As you can see in the screenshot above the “I Accept” is ticked off…

In the browser dev console I see a lot of errors, one is related the the button from what I can see:

Webserver configuration:
I ahve set the “public” holder as the root folder on the server.
I figured this out as when you follow the installation guide it does tell you to us this url to start the installation script:
image

But when you do that e.g. mydomain.com/install.php
it fails with 404 error. So I guessed that SuiteCRM (Just like WordPress and that also makes the installation more secure), is smart enough to figure out that the rest of the files is on directory level up.

Maybe this is my mistake and you need to use “mydomain.com/public/install.php” instead?

Any ideas? :thinking:

Thanks in advance.
Kind regards

Hmm nope… :thinking:
Configuring the webserver’s root to “public_html” insteads of SuiteCRM 8.5.'s “public” folder does not make any difference. The “Next” button remains grayed out…

See the screenshot below…

So at least I have ruled out that idea that is a webserver configuration issue with the root folder…

Kind regards

I have figured it out with the help of @pstevens with help video I think…
(Thanks for making that video!).

It turns out that the installation advice that you use “mydomain.com/install.php” is incorrect.

Instead you should just type “mydomain.com/#/install” (Or just type in your browser “mydomain.com” and hit enter key and then you will be redirected to "Web Hosting, Domain Name Registration - MyDomain.com").

That will produce the correct installation screen:

So success on that part! :+1:

But I do have a question still regarding the webservers configuration of the root.
As it is safer to run with the webserver using suitecrms’s “public” folder as ww root (less files exposed to the internet etc. etc. than using the default “public_hmtl” folder as www root is this a feasible web server configuration to use?

Or is SuiteCRM isn’t smart enough and will require that you use the default www root folder e.g. “public_html”?

Thanks again!

1 Like

Well new issues - it wont connect to the database and run the installation. It also doesn’t give any helpful error message. Just the blank error just like in pstevens video:

I test with charging the passwords to less complex and shorter versions. But as it seems , nothing helps with this.

I’m running out of ideas to fix this part.

Got it installed - issues is the database password - it wont accept a standard longer password. The installation only works if you use a very short DB passwords like 5-6 characters. Same bug as in 7.xx :flushed:

Now with that said I did get 8.5 “installed” and DD populated with data tables BUT it does not load the files very well:

In the logs I find this:
redacted/public_html/public/legacy/.htaccess: RewriteBase: argument is not a valid URL, referer

On the flipside changing the www root back to “public_html” instead of “public” doesn’t do much; it basically produces the same error as above screenshot and break the whole thing.

To be fair some pages are actually viewable/browsable in SuiteCRM 8.5 like accounts, leads, opportunities, quotes but on many other pages it just crashes with error 500.

See the gif recording below:
video_05

So some pages does load while others just gives you 500 internal server error. :scream_cat:

Checking the file permissions doesn’t seem to reveal anything incorrect in itself: (We’re using Plesk CP to partition our servers for various business apps/purposes)
video_04

Stuck again sigh…

Thoughts? :thinking:

Is this root folder for CRM v8.x?

/public/legacy/

Maybe you could check your Apache configuration file. You will find solution on this forum.

Nope - just…
www root public_html/public/
I could not get it to work another way. So I figured out that must be the right way to do it.

I did not consider the
/public/legacy/
example you just gave me.
Mostly because I did not think you would need to dig that deep into the system.

So should the webserver root be configured to legacy then? :thinking:

No, the below is wrong answer.

p.s. it is not correct solution.

Please don’t confuse things…

Web root is public, not public\legacy

Then you must install mod_rewrite and get that working according to the official docs, not according to “some other post somewhere”.

1 Like

Thank you for correcting, pgr :v:

1 Like

Thanks @pgr! :+1:

Then I suppose that I guessed that part right at least.

So the webserver should then be configured to use
/public_hmtl/public/
then.

Very good to know!

Well I have tossed in the towel for now - I had to get on with installing 7.xx for the client now - testing 8.5 took a good chunk of time out of my day. I kind of regret it, but i was too curious to not give it a try. :stuck_out_tongue:

7.xx also by the way gave me a small headache with wrong file perms.

For those that use Plesk control panel this could be helpful as because
resets the web server permissions of the webserver for a Plesk user account:

Replace “johndoe” with the system user name from step #2

# find /var/www/vhosts/example.com/httpdocs/ -type d -exec chmod 755 {} \;
# find /var/www/vhosts/example.com/httpdocs/ -type f -exec chown johndoe:psacln {} \;
# find /var/www/vhosts/example.com/httpdocs/ -type d -exec chown johndoe:psacln {} \;

Anyway - back to 8.5 - I can still not get my head around why it fails to load some pages - its weird. I will setup a new test install in the coming days to play with. Not sure if it is the file permissions that is trolling me. but they looked kind of fine in the gif recording above that I shared earlier.

Maybe you’re not upgrading from older version. But, you could read this post to get some ideas :bulb:

I found this on how to enable/install it on Plesk CP:

1. To enable "mod_rewrite " at your webserver apache, you could use the command for CentOS:

a2enmod rewrite

Afterwards, please restart your webserver with the command:

service httpd restart

Be aware that you need a rewrite rule, which you might place in a .htaccess - file in your document root like for example:

<IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
</IfModule>

2. To use the Image library GD, you need to install it ( and some extensions ):

yum install gd gd-devel php-gd

Afterwards, please make sure to restart your webserver with the command:

service httpd restart

3. To enable cURL, it has to be installed as well. First, please have a look to the files with cURL inside the package name:

yum search curl
Afterwards, install the needed packages with yum ( for example ):
yum install php-curl

Please make sure, that your depending php.ini 's don’t prevent the usage with a definition like:

disable_functions = exec,passthru,shell_exec,system,proc_open,popen,curl_exec,curl_multi_exec,show_source

If this is the case, please edit this line in your depending php.ini 's and remove “curl_exec,curl_multi_exec,” . I recommend only editing the domain - specific php.ini, in order to deny the cURL usage by default, with the suggested procedure, because the usage of cURL in PHP - scripts can lead to security leaks.

To locate your depending php.ini’s you could use the command:

find / -name ‘php.ini’ 2> /dev/null

If you had to install cURL or depending packages or edited php.ini’s, please make sure to restart your webserver again with:

service httpd restart

Maybe someone else here on the forums might find it helpful.

Not sure if you can use the same commands on Ubuntu server. Some Linux commands are the same; others are not…

1 Like

I did a total new fresh install of SuiteCRM 8.5.

Also the setup on our server with this 8.5 test was complete new and set up from the ground today.