SuiteCRM 8.4.1 - Google calendar sync setup

Good afternoon,

I’m trying to set up google calendar syncing on a fresh installation of SuiteCRM 8.4.1.
I have (apparently) successfully setup the google API token in the Admin panel, but when I login as a user to enable the syncing, when I click on the “Authorize” button in the Advanced tab of my user profile, I get a Not Found error.

I suspect I did not setup my URI properly:

my suiteCRM installation is on https://crm.mydomain.com, however, I have enabled URL rewrites on my web server and on a fresh install nothing was working due to a bug in the .htaccess file where a “/” had been turned into my suitecrm installation path, so I fixed that too.

My question is, does having URL rewrites enabled change what URI I need to put into the credentials configuration for it to work?
My SuiteCRM home is at https://crm.mydomain.com/#/home, however google would not let me add the /#/ to the entrypoint URI (which I put in as https://crm.mydomain.com/index.php?entryPoint=saveGoogleApiKey)

Any help is greatly appreciated.

The issue was as such:

Our CRM is hosted on an https website with a link such as “https://crm.mydomain.com

The “Authorise” button in the user settings has an onClick method which would’ve opened the window “crm.mydomain.com/index.php?entryPoint=saveGoogleApiKey&getnew

The issue was fixed when I manually added “https://” at the start of the window the button wanted to open. Otherwise, I was being sent to https://crm.mydomain.com/legacy/crm.mydomain.com/index.php?entryPoint=saveGoogleApiKey&getnew which obviously doesn’t exist.

1 Like

@gp_lnuff maybe you can open a GitHub issue so a fix gets done?

To be fair I’m not a github user so I would rather someone who does already know how to contribute properly did it. I could look into how to do it but it will take a while

@gp_lnuff what do you have in your site_url setting, in your public/legacy/config.php?

This is your URL as you specified during installation, and it is used to build many URLs in SuiteCRM. You should have that https in there.

2 Likes

Sure enough, the https was not there. Adding it fixes the link the button points to, however I forgot to add that I also had to change the target of the window.open from _self to _blank to get it to work, the google authentication page won’t open in the same window, not yielding any errors leaving just an empty page (not blank, with the SuiteCRM background and top bar).