Make a quick vote 🗳 ️How do you refer to SuiteCRM extensions: add-ons or plug-ins? Click here to have your say 👈

SuiteCRM 8.2 & 7.12 Migration beta - We need your Help!

SuiteCRM 8.2 will be an important moment in the evolution of SuiteCRM 8, as it will be the first release to include migration capabilities from SuiteCRM 7. With so much discussion on the subject and such a large number of SuiteCRM 7 users, this will undoubtedly be a significant milestone for the project.

We couldn’t fully rely on the legacy upgrade process because of the significant changes and enhancements that SuiteCRM 8 brings. The required changes in setup also means that this is more of a migration than an upgrade, involving many important steps and requires a good understanding of your current setup. That is why we need to your help in testing this first beta release, to make this process as smooth and slick as possible.

As an open source software project, it is critical that the community has the ability to not only voice and influence the project’s development, but also to guide us towards better solutions. As a result, we are looking for willing volunteers to assist in testing this process in as many different instances and setups as possible in order to identify any issues. But also to provide us with feedback, suggestions, and thoughts on your experience and the overall process.

Please use this post to discuss any issues, share feedback or general thoughts you have about your migration experience.

To find out more about the release and the migration process, please see the links below

4 Likes

Hi,
Thanks to everyone for all the hard work, it’s really exciting to be able migrate to suite8 :slight_smile:
However, my difficulties start at 2.1(2) of the migration guide , which i think needs to be clearer.

I am running 7.12.x on linux at

/var/www/crm/

I think I’m supposed to extract the contents of SuiteCRM-8.2.0-beta-7.12-migration.zip into a new folder - for example:-

/var/www/crm8/

and then copy the contents of /var/www/crm/ into /var/www/crm8/public/legacy/ and run the upgrade commands from there?

In doing the above I’ve been able to complete the upgrade scripts without error - although I’m not sure if I’m using the correct site_url in config.php and .htaccess.

Either way, when completed, and visiting the new instance, apache error log show that soap.php is missing in /var/www/crm8/public/.

:upside_down_face:

i think the migration guide needs developing further to help those like me :grinning:

Hi,
I have read all the migration documentation from SUITE 7 to SUITE 8. I have followed all the steps. When I try to log in I am getting the graphql api error.

Please find the attached screenshot of the error:

In the response, i am getting this “Invalid CSRF token”

1 Like

I am reporting the same problem as usman.arshadrt

the application posts the following payload to: /api/graphql

{
  "operationName": "moduleMetadata",
  "variables": {
    "id": "/api/module-metadata/home"
  },
  "query": "query moduleMetadata($id: ID!) {\n  moduleMetadata(id: $id) {\n    id\n    _id\n    listView\n    search\n    recordView\n    subPanel\n    massUpdate\n    recentlyViewed\n    favorites\n    __typename\n  }\n}\n"
}

I am getting the following printout from the log at /dir/to/suite/logs/prod/prod.log

[2022-07-09 15:55:09] request.INFO: Matched route "api_graphql_entrypoint". {"route":"api_graphql_entrypoint","route_parameters":{"_route":"api_graphql_entrypoint","_controller":"api_platform.graphql.action.entrypoint","_graphql":true},"request_uri":"http://<SUITECRM_URL>/api/graphql","method":"POST"} []
[2022-07-09 15:55:09] request.ERROR: Uncaught PHP Exception Symfony\Component\HttpKernel\Exception\AccessDeniedHttpException: "Invalid CSRF token" at /var/www/html/core/backend/Security/CSRFValidationListener.php line 96 {"exception":"[object] (Symfony\\Component\\HttpKernel\\Exception\\AccessDeniedHttpException(code: 0): Invalid CSRF token at /var/www/html/core/backend/Security/CSRFValidationListener.php:96)"} []

I think I’ve figured out the the site-url and rewrite settings, and can log into the new instance.
However the graphics are not working. - im getting basic html with no css or images etc.

The upgrade-finalise shows an error for libpng :-

hello,
Same error after migration from SuiteCRM7.