SuiteCRM-7.7.8 New Installation. Login not working post install. Query Failed: SELECT id FROM aow_workflow


I performed a new Installation of SuiteCRM ( My Database and File permissions have been cross-checked and I am not able to find a resolution online for the last few days.

I have an issue where I am not able to get past the Login Screen after a new installation. It just re-appears after entering credentials.

The only error is find is in the sugercrm.log and is as follows:

“[FATAL] Query Failed: SELECT id FROM aow_workflow WHERE aow_workflow.flow_module = ‘ACLActions’ AND aow_workflow.status = ‘Active’ AND (aow_workflow.run_when = ‘Always’ OR aow_workflow.run_when = ‘On_Save’ OR aow_workflow.run_when = ‘Create’) AND aow_workflow.deleted = 0 : MySQL error 1146: Table ‘lilyblu2_suitecrm.aow_workflow’ doesn’t exist”

This repeats 328 times

When I try the same SQL from my phpadmin - it works : i.e.:
FROM lilyblu2_suitecrm.aow_workflow
WHERE aow_workflow.flow_module = ‘ACLActions’
AND aow_workflow.status = ‘Active’
aow_workflow.run_when = ‘Always’
OR aow_workflow.run_when = ‘On_Save’
OR aow_workflow.run_when = ‘Create’
AND aow_workflow.deleted =0
LIMIT 0 , 30

(This returns no rows as the table is empty, but gives return code of 0)

My Server info is as follows:
PHP Version 5.6.24
MySQL Version 5.6.34
Architecture x86_64
Operating System Linux

Can anyone assist with ideas?

The actual version is 7.7.9. There is now point to install an outdated version.

Please delete your previous installation and start it over with 7.7.9

1 Like

Is the password anything special, with special characters?

It sounds like you have installed correctly as you can access the login page. Have you set up .htaccess correctly (if it is there) - check that rebase is pointing to your directory and not anywhere else.

1 Like

Hi there

Thanks for the quick reply. I did some debugging after your feedback and it looks to me as if my hosting provider did not set all of the permissions correctly recursively (many .js files had 644 permissions which I suspect s wrong) . The code gets to the right index.php, but bombs out very quickly inside a script…

I have decided to redo the effort - also using the 7.7.9 version and have asked my hosting provider to redo the permissions.

I will revert back if this solved the issue.


OK - Did a re-install with 7.7.9 and am getting the same result.

Errors I noticed:
Directly after the install I checked the Errror Log on the server and it listed something like:
“Cannot allocate memory: couldn’t create child process: /opt/suphp/sbin/suphp for "
…but today the errors are not listed anymore from my control panel.”

Error2 - post install:
The SuiteCRM Logon Page just re-appears without doing anything when logging on, but it does give me an error like this:
SoftException in Application.cpp:261: File “/home/assuredf/public_html/crm/themes/SuiteR/css/colourSelector.php” is writeable by group,
" SoftException in Application.cpp:631: Directory “/home/lilyblu2/public_html/SuiteCRM/themes/SuiteP/css” is writeable by group, referer:"

Now - I did change the permissions in the themes directory recursively for all subdirectories and files to ‘775’ before doing the install.
Should I not have done this - or is the issue with the first error and the install is not able to complete.

Appreciate any views.