Make a quick vote 🗳 ️How do you refer to SuiteCRM extensions: add-ons or plug-ins? Click here to have your say 👈

SuiteCRM 7.12.5 Installation - textmode interface

Hello everybody,

I manually installed SuiteCRM 7.12.5 (hosted externally). Chose to populate SuiteCRM with demo data.

Everything seemed fine (see installation screenshots).
The problem is that the SuiteCRM interface appears in textmode (see login + dashboard screenshot).
If I enter one account I get the detailed information (all text mode).

I Double checked permissions as per ’ Downloading & Installing’ instruction. Everything is in line.
Thought of a owner/group name error, but it is ok. I compared it with a working SuiteCRM 8 version
installed via Softaculous in another directory. Owner/group are the same.
PHP modules are there so I thought of a PHP version problem, so downgraded it from 8.0 to 7.4.28 version. Nothing changed, always text mode.

Does somebody have a clue to solve this issue?

Thanks for helping out on this.
Mario

----------- INSTALLATION ------------

--------------- LOGIN + DASHBOARD ---------------------------


That doesn’t make much sense… maybe it was the other way around? Changing 755 to 775?

They changed 775 to 755

Hi pgr,

Sorry but yesterday I was in a hurry and could not clarify things happened.

Here is the facts.
Since the issue faced and explained in this topic I contacted the web hosting support.
1st Lvl opened a ticket and got in touch with 2nd Lvl support.
After certain time they wrote telling me everything was fine (“The issue has been resolved, and the application’s login page is now displaying correctly. This was caused by incorrect permissions set for the files and folders under the cache directory.”).

So I checked and found out they changed cache dir pemission from 775 to 755.

As you wrote me yesterday, also for me that was not clear so I replied the following “I checked and as you stated now the page is displaying correctly. To tell you the truth I do not get the cause of the error you mentioned.
Now the ‘cache’ directory permission is set to 755 and before it was 775…In any case I do not get why 755 works while 775 does not, which is less restrictive for the group. What do you think?”

So they answered: “I wasn’t only referring to the permissions of the “cache” directory; there were several other files and folders under it with incorrect permissions.
More opened permissions are not always less likely to cause issues. There are often cases when 777 or 775 permissions on files and folders are considered to be too permissive, and the server restricts access as a security measure.” And at the end of the message added " Anyway, the app should work fine with 755 or 775 permissions." (???)

This did not clarify the cause of the problem, especially the last line. I was wondering if they fooled me writing about the server which may have interpreted a folder to be less restricted than it should. I understand security but never heard about a server deciding if permissions assigned to a folder are right or wrong. Upon which basis a server may decide that?! The name of the folder?!

By the way now SuiteCRM is also working properly with folder permissions set to 775.

So now I decided to deactivate my “solution” and I would delete this topic if possible, which may cause just confusion.

What is your opinion?

Thanks
Mario

There is a missing element in analyzing all this, which the file ownership and knowing the user that the web server is running under.

In those numbers 755, 777, etc, only one digit will actually get used, and that depends on this missing information I mentioned above. So yeah, it is possible that 755 is exactly the same as 775 if you’re getting access through the first digit, not the second.

This would happen if the user that the web server is running under happens to be the same as the owner of the files.

But this is all generic Linux permissions stuff, we can leave it aside if everything’s working now. :tada:

Hi pgr,

Thanks for replying.

To answer you question, user and owner are the same. This explain why it works 775 and 755 now.
Who knows why before pages displayed in text mode.

Anyway since I can use both, would it be more secure setting permission to 755?

Thanks
Mario

The less permissions, the better. For me the third digit “world access” is always 0.

But this can be more complex than you think, you might need other users accessing it (like your FTP or SSH user going in to change some files) so unless you really understand linux users, groups, ownerships and permissions, I would leave it as it is (if it is working).

I understand I am not as expert as you, but what do you think setting 770
to all directories apart ‘cache custom modules themes data upload’ which
would be set 755?

And what about the directory where SuiteCRM is installed? Is there a way
to hide it, so you access the login page just writing the domain without adding
the folder name?
I tried but do not get how to do it.

Thanks
Mario

My recommended scheme:

About the URL without the directory in it, it certainly is possible, that is a web server configuration. It is possible that your hosting provides some UI to do it, or maybe you can just ask them via support.

Ok I will have a look, hoping I can understand.

Thanks
Mario

1 Like