SuiteCRM 7.11.6 + 7.10.18 + 7.8.31 Maintenance Patch Now Available!

SuiteCRM 7.11.6 + 7.10.18 + 7.8.31 is now available to download.

Please note, this is our last supported release of 7.8.x, if you still require security updates please upgrade to 7.10.x/7.11.x

This release includes a number of bug fixes, security patches and enhancements.

For a full list please View Release Notes for 7.11.6. Release Notes for 7.10.18 and Release Notes for 7.8.31

Thank you to all community members who logged bugs and contributed to this release.

All input is welcome.

The SuiteCRM Team.

1 Like

After update from 7.11.5 to 7.11.6 (Everything seemed to go well) until the end -> Blank page.

Now, when going to Admin -> Upgrade Wizard = Blank page.

Error from Apache log:
[Mon Jul 01 16:48:33.783718 2019] [php7:emerg] [pid 4485] [client XXX:44698] PHP Parse error: syntax error, unexpected ‘$files’ (T_VARIABLE) in /XXX/cache/upgrades/temp/wqFUAR/scripts/files_to_remove/UpgradeRemoval65x.php on line 849, referer: https://XXX/index.php?module=Administration&action=index

Any idea how to fix this?

1 Like

Hi larsaamodt,

Thanks for the feedback, it looks like there was a syntax error in some of the upgrade packs. This has now been corrected so you should be able to re-download and give it a try. Let me know if you encounter any more issues.

Thanks, Dillon.

1 Like

Thank you!

I had to start over with new install (export and import of records) since i forgot backup.

Will remember backup next time :slight_smile:

Just updated from 7.11.5 to 7.11.6

Small thing : In the about tab I got this :

Version 7.11.7
Sugar Version 6.5.25 (version de construction 344)

Is this 7.11.6 or 7.11.7 :stuck_out_tongue: ?

Not a major issue, will stay with this version because the update worked well. Just for information :slight_smile:

i wondered about this too

Just got this error message when tried to install a fresh suite

Using WAMP software

PHP : 5.6

07/02/19 08:46:41 [16240][-none-][FATAL] Error creating table: users: Query Failed: CREATE TABLE users (id char(36) NOT NULL ,user_name varchar(60) NULL ,user_hash varchar(255) NULL ,system_generated_password bool NULL ,pwd_last_changed datetime NULL ,authenticate_id varchar(100) NULL ,sugar_login bool DEFAULT ‘1’ NULL ,first_name varchar(255) NULL ,last_name varchar(255) NULL ,is_admin bool DEFAULT ‘0’ NULL ,external_auth_only bool DEFAULT ‘0’ NULL ,receive_notifications bool DEFAULT ‘1’ NULL ,description text NULL ,date_entered datetime NULL ,date_modified datetime NULL ,modified_user_id char(36) NULL ,created_by char(36) NULL ,title varchar(50) NULL ,photo varchar(255) NULL ,department varchar(50) NULL ,phone_home varchar(50) NULL ,phone_mobile varchar(50) NULL ,phone_work varchar(50) NULL ,phone_other varchar(50) NULL ,phone_fax varchar(50) NULL ,status varchar(100) NULL ,address_street varchar(150) NULL ,address_city varchar(100) NULL ,address_state varchar(100) NULL ,address_country varchar(100) NULL ,address_postalcode varchar(20) NULL ,deleted bool NULL ,portal_only bool DEFAULT ‘0’ NULL ,show_on_employees bool DEFAULT ‘1’ NULL ,employee_status varchar(100) NULL ,messenger_id varchar(100) NULL ,messenger_type varchar(100) NULL ,reports_to_id char(36) NULL ,is_group bool NULL ,factor_auth bool NULL ,factor_auth_interface varchar(255) NULL , PRIMARY KEY (id), KEY idx_user_name (user_name, is_group, status, last_name, first_name, id)) CHARACTER SET utf8 COLLATE utf8_general_ci: MySQL error 1071: Specified key was too long; max key length is 1000 bytes

This is a MySQL error, so PHP version is not relevant.
Make sure your MySQL database is set up with Innodb tables. (Is it ISAM now?)
Is this a x86 system?
Maybe try the solutions in the Google search for the error: MySQL error 1071: Specified key was too long; max key length is 1000 bytes
Good luck

Hi !!
I had the same issue. I updated from 7.11.5 to 7.11.6, but finally I’ve 7.11.7 version B-)

Apparently everything works fine :unsure:

Thanks, Sergio

Hi Everyone, That is the upgrade packages updated to include the correct suitecrm_version.php 7.11.6

Recommend you change that file itself as that is the only file change :smiley:

Does it change something to the file/update ? Or its just to display the correct version ?

Cause I honestly dont care If its displayed 7.11.6 or 7.11.7, will wait for the next update ahah (The real 7.11.7 :p)

In this upgrade there was an increase of field characters (user_name & password) which combined increased the index key over a MySQL 5.6 threshold of 1000 (MyISAM) or 767 (InnoDB) (apparently). MySQL 5.7 has a higher threshold which is 3072. However ontop of that threshold your character encoding also contribute to this… in this case it’s UTF8 which uses up the max space… Apparently looking online it seems if you change your charset to latin1 it will potentially be within the threshold (install_utils.php)

I’ll raise this as a Github issue as I’m sure it will be highlighted as our config.php states ‘default_charset’ => ‘UTF-8’,

@holdusback it’s possible that when you try the next upgrade, it will tell you that you already have 7.11.7 and won’t let you upgrade… any way, this is a really easy change.

1 Like

That is the only file change :slight_smile:

1 Like

Hi Ashish,

What version of MySQL are you using?
With 5.6 and 5.7 I cannot reproduce it.



I am using

Server version: 5.7.23 - MySQL Community Server (GPL)

Main difference i am on windows 10… May be this is issue?