Suite CRM login only workes in incognito in chrome

Dear Users!

Last day my suite crm thinked big, and stoped working normaly.
I cannot login from any browser, only from chrome incognito mode.
I tried to search to forum but no luck.
Quick repair, htaccess rebuild, nothing helped.
When i cleared the cache on 1 users browser after that i can login.
Any idea about this.
My install is on debian azt suite 7.11.3.

Thanks for the help!


Hi @bolvar,

Welcome to the Community! :tada:

I imaging as you said cleaning cache would be the quickest fix for this. If it consistently happens we can investigate this further.

Dear @Mac-Rae!

So there are no official solution for this problem?

Check if you ran out of disk space in the server.

Check your logs for clues on what exactly is breaking.

Dear @pgr!

I have plenty of space, and if it is full the cache clear would not help i think.
There was no modification on the server so its a very weird bug.

In the logs i only find this:

Tue Jan 14 13:45:09 2020 [1983][-none-][WARN] CSS File Dawn/yui.css not found
Tue Jan 14 13:45:29 2020 [1831][6ab244b3-1d06-9a74-0abe-5ca38a882020][DEPRECATED] Array

I dont know it helps.


That’s suitecrm.log.

What about the web server log? Check your php.ini to enable it, or to set the path.

Dear @pgr!

And in which log file do i have to check? There are a lot of options, in the apache logs i didnt see anything.

This is i get when i try to login. - - [14/Jan/2020:14:18:51 +0100] “POST /index.php HTTP/1.1” 302 2877 suite.xy/index.php?action=Login&module=Users&login_module=Home&login_action=index"
“Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKi$ - - [14/Jan/2020:14:18:51 +0100] “GET /index.php?module=Home&action=index HTTP/1.1” 301 457 suite.xy/index.php?action=Login&module=Users&login_module=Home&login_action=index” "Mozilla/5.0 (Windows NT 10.0;$ - - [14/Jan/2020:14:18:51 +0100] “GET /index.php?action=Login&module=Users&login_module=Home&login_action=index HTTP/1.1” 200 4502 suite.xy/index.php?action=Login&module=Users&login_module=Home&login_actio$ - - [14/Jan/2020:14:18:51 +0100] “GET /themes/SuiteP/css/colourSelector.php HTTP/1.1” 200 246 “suite.xy/index.php?action=Login&module=Users&login_module=Home&login_action=index” “Mozilla/5.0 (Windows NT 10.$ - - [14/Jan/2020:14:18:54 +0100] “GET /index.php?module=Alerts&action=get&to_pdf=1 HTTP/1.1” 200 372 suite.xy/index.php?action=Login&module=Users&login_module=Home&login_action=index” "Mozilla/5.0 (Windows$ - - [14/Jan/2020:14:18:54 +0100] “GET /index.php?module=Alerts&action=get&to_pdf=1 HTTP/1.1” 200 973 “suite.xy/index.php?module=Opportunities&action=index” "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWe$

I deleted the https:// because users can only publis 2 links in a comment.

No, that is not the correct log.

As I wrote above, open your php.ini file and check the settings there, or set them.

To find out your `php.ini´ path, go in Admin / Diagnostics / phpinfo.

See where your php.ini is, in case you need to change it. You can also check the values for


Please see online PHP documentation to learn about these values. Thanks.

Dear @pgr!

My php.ini is located under /etc/php/7.0/apache2

Im not a web programer :slight_smile: . Just want to use this crm for basic things.

In the error log i didnt see any entry after the failed login.

[Tue Jan 14 14:36:06.567627 2020] [:error] [pid 2539] [client] PHP Notice: Undefined index: comment in /var/www/suite/modules/Administration/DiagnosticRun.php on line 697, referer: https:suite.xy/index.php$
[Tue Jan 14 14:36:06.567634 2020] [:error] [pid 2539] [client] PHP Notice: Undefined index: required in /var/www/suite/modules/Administration/DiagnosticRun.php on line 698, referer: https:suite.xy/$
[Tue Jan 14 14:36:06.567642 2020] [:error] [pid 2539] [client] PHP Notice: Undefined index: dbType in /var/www/suite/modules/Administration/DiagnosticRun.php on line 695, referer: https:suite.xy/index.php?$
[Tue Jan 14 14:36:06.567654 2020] [:error] [pid 2539] [client] PHP Notice: Undefined index: len in /var/www/suite/modules/Administration/DiagnosticRun.php on line 696, referer: https:suite.xy/index.php?mod$
[Tue Jan 14 14:36:06.567661 2020] [:error] [pid 2539] [client] PHP Notice: Undefined index: comment in /var/www/suite/modules/Administration/DiagnosticRun.php on line 697, referer: https:suite.xy/index.php$
[Tue Jan 14 14:36:06.905820 2020] [:error] [pid 2539] [client] PHP Warning: opendir(cache/diagnostic/caf43bc1-66cb-c67c-fdd6-5e1dc37a78cb/diagnostic20200114-143540/): failed to open dir: No such file or directory in /$

I have no error_reporting log, and in the error_log this is the last entry.


Now you’re looking in the correct place :smile:

Are you sure nothing comes up there when there is a failed login?

What about in your browser, in the Developer Tools, Java console, do you see any Javascript errors appearing when it fails?

We need some clues otherwise there is no way to know what needs to be fixed :man_shrugging:

What you wrote above doesn’t seem consistent to me…

  • either you have a server-side problem and no user can log in
  • or you have a client-side browser problem which should affect only one user
  • clearing a local cache shouldn’t make a difference for server-side problems…

Dear @pgr!

Sadly nothing between the two logins :confused:

All users are infected about the login, i just tried at one user that the cookie delete helps or not.
But because we need to use it, all of the users has to clear the cookies to work.
But i can login, just in incognito mode, so im dont know where should i search the problem.

I have one warning if i open the chrome console,

Other things you can check:

  1. did you upgrade recently? From which version, to which version? Was that when this problem began?

  2. In your php.ini, there is a setting called session.save_path. Check if that directory is writeable by your web server process, and if it has an excessive number of files.

  3. Do you have any add-ons, especially any one related to log in, even if it simply changes the background image in the login page? Do you have any custom themes installed?

  4. Do you have anything in custom dir that could be conflicting with recent code changes? Anything under application directories, or modules/Home

Dear @pgr!

There was no update in the crm or the debian server, on friday worked, on monday not.

Session save path is commented out but here is the path:"/var/lib/php/sessions"

We have buyed two add on(But this wasnt made by me) : SuiteCRM Field Level Access Control and Dynamic Panels.

No custom theme or background change was made.

Under Models/Home there are a dashlets.php, under Application ther are Ext folder with a few other folder like EntryPointRegistry Include Language LogicHooks TableDictionary.

I am just giving directions to explore, you need to dig in deeper in order to troubleshoot your system. In all my years here I have never heard of a problem like yours :thinking:

In one of the systems where you can log in, please go in Admin / Diagnostics / phpinfo and download that file. Then open it and check your _ effective_ session.save_path and go check that path on Linux.

As a simple test you could also rename the custom to something else directory to see if the logins start working. But note that this will break things in your system, it’s just a test and then you would have to put it back. The point is just to find out if the problem seems to be coming from there or not.

Okey i downloaded all the diagnostic info but, i didnt made any changes so its hard to find the problem that not i made :smiley:

Chrome was updated yesterday maybe there is the problem.

The patch is okay i dont know what should i see
root@suite-eles:/var/lib/php/sessions# ls
sess_1gjdnbrg98fn9lqq198haaleb4 sess_7lrhvffq5the0olfa84sgr6ku6 sess_e87ot8flc430ek2due5aro91o1 sess_g4n37ll6srdfetdvvm3a0r5pd1 sess_j0dvg81p898ks0ha15b0lkodp2 sess_mbp8fklfg6qlo5dosbl3u32o86
sess_5jvtf1apo8364p4gr4h2vfsfb4 sess_7m7t4093rte09h0co7ifcsfmr1 sess_f1d9447f9b5b4bb4169bbba187409d1b5f9b8836 sess_hq26jv44orp4phs5o91r4dk7o7 sess_j5ga4b4mb9i69gr10oesvs1re0 sess_ohrr7v688gaofne342bfanatd7
sess_7161qkmdn2kjrfbvgb7acq3rv5 sess_83esd6dkgm45l22evj51gt8335 sess_fmm3hpt17nod3csgs533c43465 sess_i3l4rnkfvgmlbbl6600gv1jgl6 sess_k6t3bm99otudhg3jdbbeqnaq13 sess_p1rbetqf85lveav8lsbb1d4c05

I see this under the path.


What you could see there is a million files (a problem I’ve seen happen to other people, the directory just grows and grows), or wrong permissions.

If you use ls -al you can see file ownerships and permissions, and timestamps.

But it looks fine, if you see relatively new files from the last logins, it seems to be working well.

In that case you will need to explore the other pointers I gave you…