Suite 8 : Installing on NGINX


is there also already a way for nginx deployment of 8beta, RC?

Thanks in advance.

Hi @chriswithadot,

Replied on:

How do you get to the admin panel on Suitecrm8 i just have this but cant access the panel.

Hi @D3rv,

Thanks for trying out SuiteCRM 8 and for the feedback.

What you are seeing is a “legacy” / “classic” view that is not meant to be accessed directly.

Just a few question to try to understand the problem:

  1. Is the vhost configuration your instance setup to point to /<path-to-suitecrm-8>/public, example: /var/www/public?

  2. Are you trying to access something like https://<your-crm-domain>/public/legacy or https://<your-crm-domain>/legacy?

It’s /car/www/suitecrm/public/legacy.

If I don’t have legacy on the end it just has a blank white screen

Hi @D3rv,

Thanks for the feedback.

There have been other people with the same problem, usually it was related with mod_rewrite not being enable or not allowing re-writes.

However, to allow to understand the problem, could you try the following please?

  • Open a new tab and then open the network tab of your browser’s devtools.
  • go the the your instance on the tab you’ve just opened (just on public, not of legacy).
  • On the network tab there should be some graphql calls.
  • Could you check which ones are failing please?

i get this when i user public

i notice it says failed to load script

EDIT: ok so after doign a bit of looking up i added
try_files $uri @rewrite_api;
in my nginx config file.

this now brings up a plethora of things in cluding the grahpiql you asked about

Also trying gives me a 404

Hi @D3rv,

Thanks for the feedback. That explains the problem.

At the moment we don’t fully support nginx. Mostly due to the legacy code.

However, the current error is related with the Suite 8 side code. Symfony is not picking up the routes.

This symfony guide may help:

Though, if possible, it maybe be best to use apache while we don’t add full support for nginx ( which may take a while)