Suite 7.9.0 - Email Quotation

Hello There

I have tested 7.9 for “Email Quotation” and it takes me to a blank screen?

I have connected my email address and am able to compose and send emails

Just checking if anyone else if having same issue?

Thanks again

I get the same result, this looks like a bug.

My logs show this:

Mon Jun  5 16:39:10 2017 [1252][1][FATAL] emails_email_templates for emails_email_templates failed to load
Mon Jun  5 16:39:10 2017 [1252][1][FATAL] Failed to load relationship emails_email_templates while saving Emails
Mon Jun  5 16:39:10 2017 [1252][1][FATAL] emails_email_templates_idb for emails_email_templates failed to load

There was another bug fixed very recently (not yet released) that had the same symptoms (failed to load relationship). I wonder if that fix also fixes this…

This is bug same error in my upgraded from 7.8.3 version and from fresh install of 7.9

In the moldule Emails the compose.php on line 72 point this


But the index.php on email module is deprecated in 7.9

if i copy from 7.8.4 this file and put on 7.9 the quote found with the old interface of Email (like 7.8.4).

1 Like

Issue created in Github

Thank you both for your input!

Is there a workaround for this issue to test? Will removing the call on line 72 “fix” the problem?

You can try it, but I don think removing the line will help, it probably needs to be replaced with a call to the new email client.

Let’s hope that soon these “Medium priority” email bugs get fixed, since the “high priority” ones are already finished…

I have the same issue but I am sure its just started as last week it was working I am using suiteCRM

Version 7.10

Sugar Version 6.5.25 (Build 344)

Do we have a fix for this, please.

When you say “last week”, which version were you running? Did it stop working after an upgrade, or did it just stop working?

You can add your voice on the issue on GitHub.

It started happening when I was using ver 7.7 and when I upgraded to 7.10 hope it may fix the issue.

I have now found the issue was what I have enabled AOD if I switch it off the Quote -> email PDF works ok.

Thank you for taking the time to replay


@jsm25 would you mind turning it on again (and breaking your system again :slight_smile: ) and then checking the logs to tell us what you find there at the time of the error? We need more information to fix this.

Please check both suitecrn.log and php_errors.log

Thanks for helping debug!

I have attached file hope they help to resolve the bug. If you need anything else from me please let me know.


@jsm25 you have a FATAL error causing your AOD scheduler job to fail. I don’t see any reason why this would affect the Email quotation functionality (unless that record causing AOD to fail is a Quote record?)

You might want to try reindexing AOD instead of turning it off (so you can still use global search).

But I’m still intrigued by this error. The old issue mentioned above is "supposedly) already fixed.

What are the steps you take to get that error? In which module are you, what do you click? I want to try and reproduce it here. Thanks once again.