SugarCE 6.5.x upgrade: "Upload Package fails"

Hi there,

I’m running a Sugar CE instance on my mac, Version 6.5.15 (Build 1083). I’m trying to upgrade it to SuiteCRM using the migration file SugarCE Migration 6.5.x to SuiteCRM

I first tried the silent-upgrade (for the first time in my life), but that didn’t work, despite giving me a success message at the end (after only a few seconds).

Not I’m trying with the Upgrade Assistant and in step 2 after choosing the upgrade package file and click on “Upload Package” I see the message “ has been uploaded.”

Yet in the following section (just below the Upload button) titled “The following upgrade packages are ready to be installed:” nothing is shown (“none”).

When I click on “Next” I see the red error message “Upload a package before continuing.”

So I’m stuck.

I’ve given liberal permissions (775) to all files in the sugar directory, including the upgrade file. owner is the apache user.

I’ve also tried setting permissions and ownership of the files in the folder /uplaod/upgrades/patch that Sugar creates upon upload of the zip package. This didn’t help either.

Any help appreciated!


Hi there,

Did you browse and select the package, and then click upload? If the package is not uploading, it is most likely permissions on the upload directory.

What is your setup, so that we can recommend permissions to set?



Hey there Will

What would you like to know? I’ve described my system and very liberal permissions (It’s a local test installation).

I did click upload. As I’ve described I get the message “ has been uploaded.” But then get stuck after:

Any help still appreciated.


Hi John,

Please try setting the following:

sudo chown -R owner:group .

sudo chmod -R 755 .

sudo chmod -R 775 cache custom modules themes data upload config_override.php

Where the owner/group is the user of the system i.e. apache/www-data.

If this does not resolve the issue, please check your php.ini and set the following recommended settings:

upload_max_filesize = 60M
max_execution_time = 200
post_max_size = 120M