successful advanced installation... but error.log.

… but attached is the apache error.log. Just for information by now.
The system is ElementaryOS (Ubuntu 12.04). I’ll be following the log to see if there is something else.

[Tue Oct 22 07:55:13 2013] [error] [client] PHP Warning:  mysqli_connect(): Headers and client library minor version mismatch. Headers:50532 Library:100004 in /home/daniel/git/test/SuiteCRM/include/database/MysqliManager.php on line 278, referer: http://localhost/sc1/install.php
[Tue Oct 22 07:57:01 2013] [error] [client] PHP Warning:  Invalid argument supplied for foreach() in /home/daniel/git/test/SuiteCRM/modules/AOW_WorkFlow/AOW_WorkFlow.php on line 89, referer: http://localhost/sc1/install.php
[Tue Oct 22 07:57:18 2013] [error] [client] PHP Notice:  Undefined index: aos in /home/daniel/git/test/SuiteCRM/modules/AOS_Contracts/AOS_Contracts.php on line 43, referer: http://localhost/sc1/install.php
[Tue Oct 22 07:57:37 2013] [error] [client] PHP Notice:  Undefined index: moduleList in /home/daniel/git/test/SuiteCRM/modules/AOR_Reports/AOR_Report.php on line 83, referer: http://localhost/sc1/install.php
[Tue Oct 22 07:57:37 2013] [error] [client] PHP Warning:  Invalid argument supplied for foreach() in /home/daniel/git/test/SuiteCRM/modules/AOR_Reports/AOR_Report.php on line 85, referer: http://localhost/sc1/install.php

Hi Daniel,

Please perform a quick repair & rebuild on your SuiteCRM instance. Did you get your SuiteCRM package via the official download link or from GIT?



This instance, was downloaded from sourceforge. I’ve just run a quick repair & rebuild, and it was successful, but did not create any database or field as a consecuence to this. Anyway seems to work fine.

Some days ago, downloaded from git, an when I ran R&R, it created databases.

This machine has MariaDB 10.0.4 installed. That’s why i think we have a version warning.

Hi Daniel,

Thanks for the feedback. SuiteCRM should fully support MariaDB use. We will look into this and find out if it is a compatibility issue with MariaDB, or whether it is a bug with the install.



I am running Mysql at Dreamhost and getting exactly the same error message from the installation.

Warning: Invalid argument supplied for foreach() in /path/to/suiteCRM/modules/AOR_Reports/AOR_Report.php on line 85

I just downloaded 7.1.1 Max from the suiteCRM website. This is a new install with no existing data or database. At first I didn’t think it was a problem because everything seemed ok until I tried to use Studio to start adding custom fields. It says “Undefined” all over the place and I can’t add any custom fields because it generates error messages. The log file is empty.

Additional threads where users are having the same issues:

Based on the instructions in the other topics, I executed a “Quick Rebuild” on my brand-new shiny installation. It made some adjustments to the database to make it match the vardefs. Frankly, this shouldn’t be necessary on a NEW install.

Now the “undefineds” are gone, but I still cannot add a new field to leads or contacts. I still get the previously reported error.

Ok, now the apache logs are being helpful

Permission denied: file permissions deny server access: /path/to/suite/cache/jsLanguage/en_us.js

When I look it’s set to read only by user and group. There is no world read :confused:

chown’ing and chmod’ing the files fixed that. After more research, it seems that there’s a problem with the php.ini. I need to turn off error checking. UGH! I’m on a shared host. Not sure how this is going to work out.