Subpanel resetting the fields back to default, when customizations are installed back.

Hello Experts,
I need some direction or advise on why this is happening.

Here is the scenario,

I have setup SuiteCRM 7.9.2 version on my windows 10 machine. WAMPserver 3.0.6 is running on my machine.
I created a few custom modules in “Module Builder” and deployed them. Later, in Studio i selected one of my custom module and then proceeded to create relationships with other custom modules I had created and deployed using “Module Builder”. Once the relationships were created successfully, i went to the respective subpanels within that module in the studio and added the fields that needed to be displayed. I ran a save and deploy for each of the sub-panels likewise. Ran and saved the zip using the export customization of all my related modules from the studio.

Once again i redeployed the entire package from the Module builder to make sure all customizations are rewritten and wiped off and ran a QRR. Then installed the customization i had exported earlier and ran a Quick Repair and when i click on the module in studio and then over to the subpanel the fields are all reset to the default fields. Is this supposed to be the default behaviour or is this a bug i am not aware off or i am completely off the mark.

I cleared all cache from browser, ran QRR’s and built relationships in repair section.
Tried in incognito mode of the browser to make sure nothing is being cached.

Why is this happening ?

When you run the QRR did you scroll down all the way to the bottom? Sometimes it offers to update database fields there (when they don’t match the vardefs).

You have to click to make it happen. Many times people don’t even see that message because it’s down below…

I did scroll all the way down on the QRR screen, but did not see any query to be executed. QRR finished with all success.


In your first post, you say you “wiped off” and then re-installed your customizations. How exactly did you “wipe off”? Reinstall the whole server? Deleted the database?

No the database was intact. i redeployed the entire custom package that i had built in the MB. that way i assumed that all relations and customizations are wiped off as the modules get installed when deployed from MB. Then i proceeded to reinstall the customization to see if the fields showed up in the subpanel again in the studio. It did not and was showing all default fields for all panels within the subpanel menu in studio.
The database was anyway empty tables that were created due to the modules that were deployed and i did not add any data into it when i did the customization of setting up relationships and subpanel field display of the related modules in studio.

I also tried to uninstall all custom modules and customizations, along with QRR, and restarted the entire process of deploying the modules and then the customizations respectively. still no luck to see the panel changes. However the relationship would show up correctly when the customizations were installed from the module loader.

I’m afraid your entire process might be betraying you. All this reinstalling the same thing over what is already there… and creating the fields but not adding any data, then redeploying? You can easily have broken something, that kind of thing isn’t very tested.

Yo can try adding your customizations on this online demo, it allows admin access:

That way you can find out if the problem is in the package or in your system… that will be a start for your investigations…

Also, remember to check your logs, they might be telling you exactly what the problem is.

1 Like

Hello sir
Even i am facing the same issue i cannot able to update the contacts sub panel (Documents) list view its getting reset every time. Please help me to get out of this.