Stuck at step 2 - no error message


I’m new to SuiteCRM and got already stuck at the install.

What I did:

  • Download latest version (then tried out LTS)
  • Unpacked it on my server
  • Changed persmissions on files and folders. Note: I can’t find the config_override.php file.
  • Launched install process
  • Old PHP version detected although I have version 7 installed. Not sure if this matters
  • System environment check: All fine
  • Database configuration: I enter all the details then click "next
  • Nothing happens: no error messages, just nothing.

Any idea what I did wrong?


System details: CentOS with Apache 2.4.33, PHP 7.0.29 and 10.1.32-MariaDB

I’m suspicious of that PHP version error, you can have more than one version on your system, and maybe the correct one isn’t being used.

Check your logs, there should be more there

php_errors.log (or errors.log, whatever your Apache log is called)

Focus on FATAL and ERROR messages, at the time of the blank screen.

I have the Exact same problem except it didn’t complain about php.

What “logs” are you referring to? There’s nothing in the Apache log. And I couldn’t find any SuiteCRM logs. I ran a find and there is no suitecrm.log anywhere on the box.

I’m using MySQL, Apache2, and Debian 9. DB is on localhost (which is what I entered). I tested at the command line using the DB creds I’m entering and they’re fine.

Zero errors or feedback on what’s the problem - just loops back to the SuiteCRM Step 2.

Oh, and then of course I get to reenter all the info in “More Options” again because it doesn’t remember that…

You find the install log directly at the root of your CRM folder.

In my case: There was no real error message in that log, in particular nothing linked to PHP. I re-did the whole install from scratch and this time it worked. My impression is that it was linked to the permissions.

Just to clarify: There was not a blank page after step two, but the page rather remained at page to, not loading anything new.