Still having trouble entering modules


I posted some while ago about that when i enter a module, i get page with no search results. To get some results, i need to do do a serch first.

I have now upgraded to the latest versions of SuiteCRM, and i still get the problem.

What it looks to me is that there is a default “search missing” somewhere. Are these hidden in the db somewhere?


Looking at your previous thread and to answer your very first question, yes there is.

“Is there a config-setting that would automatically display content from each module without having first to “Perform a search using the search form above”?”

Have a look inside your config.php or config_override.php file.

Look for the key of ‘save_query’. What value is it? The value ‘all’ is usually the default for this so this would be the value I suspect you want to have.
However if it has a value of ‘populate_only’ then it will only populate your search criteria but not actually execute the search itself - perhaps why you aren’t seeing results and only until you hit ‘Search’ does it execute.

all = Populates last search and executes it
no = Discards last search and executes a empty search
populate_only = Populates the search criteria but doesn’t execute

If that doesn’t solve your list view my only other suggestion which wasn’t mentioned was to reset your user preferences as there maybe something confusing the session and saved filters.

Let us know how you get on.

1 Like

Bingo! That was it: save_query had populate_only. In the same time i found the search_wildcard_char and search_wildcard_infront setting :slight_smile: Now it’s easier to do searches when not having to type the %-char, and i can just add the wildcar in the end of my search-criteria :slight_smile:

I actually forgot earlier to reset my profile. I did that, and now all seems to run smoother than before… Not sure if i just my imagination, but it feels “faster” :slight_smile:

Thanks for your help!!

1 Like