Sprite Support not support with host.

Sorry for the newb question, been searching the forums of this and no dice.

I was able to get the install up and running, filled out the set up, crash on install with a 500 error, had to remove everything. Subdomain, database, files, the whole install.

Same error a second and third time, apparently the host I have does not support Sprite Support.

Is there a way around this?

You probably just need to enable a few PHP modules in your php.ini or in your CPanel. There should be errors in your logs giving you clues.

The modules that SuiteCRM needs are usually not problematic for Hostings to provide.

Did you follow the set up guide before attempting to install?

To my knowledge sprites should be supprted by the browser and not the server! (maybe I am wrong though!)

I don’t understand all you are trying to say because I see some contradiction:

–> OK so everything is OK (?)

–> Sorry but I don’t understand what you are trying to say here

–> But you just said you were “able to get the install up and running”! Please be more specific!

I just have the impression that you didn’t follow the set up guide:

You should pay SPECIAL ATTENTION to:

If you don’t you are most likely not going to be able to get your system working.

In any case you have to follow all the instructions provided!

Concerning your failed installation:
. SuiteCRM version?
. PHP version
. Operating System
. Webserver and Database

Are there any entries in the SuiteCRM logs (check also the install log).
And in the PHP/webserver log?

These are fundamental informations to start diagnosing what is going wrong!

Hey there,

I check the logs,

This seems to be the only error popping up in the log.

PHP Warning: require_once(include/utils.php): failed to open stream: No such file or directory in /hermes/walnaweb04a/b95/pow.matrixgroupi/crm/install.php on line 44
PHP Fatal error: require_once(): Failed opening required ‘include/utils.php’ (include_path=’.:/usr/local/lib/php-7.1.1-precise/lib/php’) in /hermes/walnaweb04a/b95/pow.matrixgroupi/crm/install.php on line 44

To confirm, I am able to get to the install page of suiteCRM, I was able to input the database information, after several tries of getting a database host/user/password error, I was able to get the install to initialize. It seemed to of finish then redirected to a 500 error. Locked me out having to force a clean install and database dump. Only to repeat a second and third time.

I am running on a Macos, and for the life of can not figure out how to do the permission setup in the first step. Is that on my computer, or the web host. There is no option with Powweb to allow me to set the permission in by doing sudo.

I am slightly inexperienced when it comes to working with sudo and terminal. But willing to learn or figure it out. There just isn’t a guide on how to do it that make sense to me on a Mac.

Yeah, after I enter the data base information I get his with this

Creating SuiteCRM configuration file (config.php)

Creating SuiteCRM application tables, audit tables and relationship metadata
Creating the database suitecrm on matrixgroupi.powwebmysql.com…Could not connect to the database. Please refer to suitecrm.log for details (2). Fatal error: Uncaught Exception: Could not connect to the database. Please refer to suitecrm.log for details (2). in /hermes/walnaweb04a/b95/pow.matrixgroupi/crm/include/utils.php:1777 Stack trace: #0 /hermes/walnaweb04a/b95/pow.matrixgroupi/crm/include/database/MysqliManager.php(329): sugar_die(‘Could not conne…’) #1 /hermes/walnaweb04a/b95/pow.matrixgroupi/crm/include/database/DBManagerFactory.php(150): MysqliManager->connect(Array, true) #2 /hermes/walnaweb04a/b95/pow.matrixgroupi/crm/include/utils.php(3351): DBManagerFactory::getInstance() #3 /hermes/walnaweb04a/b95/pow.matrixgroupi/crm/include/utils.php(1775): sugar_cleanup() #4 /hermes/walnaweb04a/b95/pow.matrixgroupi/crm/include/database/DBManager.php(355): sugar_die(‘Database error…’) #5 /hermes/walnaweb04a/b95/pow.matrixgroupi/crm/include/database/DBManager.php(328): DBManager->registerError(’ Query Failed: …’, ’ Query Failed: …’, true) #6 /hermes/walnaweb04a/b95/pow.matrixgroupi/crm/include/database/MysqliManager.php(179): DBManager->checkError(’ Query in /hermes/walnaweb04a/b95/pow.matrixgroupi/crm/include/utils.php on line 1777

Tables have been created, the page just stalls, if I refresh to or anything I am hit with a 500 error.

The SuitCRM.log
Wed Feb 27 15:30:09 2019 [14646][-none-][FATAL] Could not connect to DB server matrixgroupi.powwebmysql.com as crm. port : Access denied for user ‘crm’@‘’ (using password: YES) Wed Feb 27 15:30:59 2019 [16264][-none-][FATAL] Mysqli_query failed.

Wed Feb 27 15:30:59 2019 [16264][-none-][FATAL] Query Failed: CREATE DATABASE suitecrm CHARACTER SET utf8 COLLATE utf8_general_ci: MySQL error 1044: Access denied for user ‘crm’@‘10.%’ to database ‘suitecrm’

Wed Feb 27 15:30:59 2019 [16264][-none-][FATAL] Could not connect to DB server matrixgroupi.powwebmysql.com as crm. port : Access denied for user ‘crm’@‘10.%’ to database ‘suitecrm’

I am going to assume this is because of the missed step with the sudo that I don’t know how to do, because I have no clue how idea where to do the sudo.

I don’t know how to set permissions on macos nor do I know for sure if it should be a problem under macos (however I am inclined to believe it is since macos is based on linux).

So until you fix permissions I believe you will not be able to get it working.

Have you tried searching google?

Maybe reading a few articles, even related to SugarCRM set-up under macos, will give you some hint:

(there are links to permissions “focus”)


MacOS is exactly like Linux once you are in the command-line. You can use the normal Linux commands there (or even run amairussi’s script!)

But your error seems to imply that the database isn’t letting you log in, and this has nothing to do with Linux permissions. You need to check your host address, user name, and password, and any other security restrictions in MySQL.

1 Like