[SOLVED] Save & Deploy don't work for List Layout in Account - Studio

SuiteCRM 7.11.10

Hello All,

I need to change my List View for Accounts in Studio.

I make the changes:

Then I Save & Deploy (successfully, kind of):

No changes are applied:

I don’t find nothing special about that in the logs. Only a mysterious FATAL ERROR :ghost::

[116657][1][FATAL] Exception handling in /srv/data/web/vhosts/my.url/htdocs/include/MVC/Controller/SugarController.php:400
Wed Dec 18 02:06:48 2019 [116657][1][FATAL] Exception in Controller: Failed to parse Host URL 'http://'
Wed Dec 18 02:06:48 2019 [116657][1][FATAL] backtrace:
#0 /srv/data/web/vhosts/my.url/htdocs/lib/Search/ElasticSearch/ElasticSearchClientBuilder.php(177): SuiteCRM\Search\ElasticSearch\ElasticSearchClientBuilder::sanitizeHost(Array)
#1 /srv/data/web/vhosts/my.url/htdocs/lib/Search/ElasticSearch/ElasticSearchClientBuilder.php(63): SuiteCRM\Search\ElasticSearch\ElasticSearchClientBuilder::loadFromSugarConfig()
#2 /srv/data/web/vhosts/my.url/htdocs/lib/Search/ElasticSearch/ElasticSearchIndexer.php(87): SuiteCRM\Search\ElasticSearch\ElasticSearchClientBuilder::getClient()
#3 /srv/data/web/vhosts/my.url/htdocs/lib/Search/ElasticSearch/ElasticSearchIndexer.php(583): SuiteCRM\Search\ElasticSearch\ElasticSearchIndexer->__construct()
#4 /srv/data/web/vhosts/my.url/htdocs/modules/Administration/repairDatabase.php(179): SuiteCRM\Search\ElasticSearch\ElasticSearchIndexer::repairElasticsearchIndex()
#5 /srv/data/web/vhosts/my.url/htdocs/modules/Administration/QuickRepairAndRebuild.php(142): include_once('/srv/data/web/v...')
#6 /srv/data/web/vhosts/my.url/htdocs/modules/Administration/QuickRepairAndRebuild.php(124): RepairAndClear->repairDatabase()
#7 /srv/data/web/vhosts/my.url/htdocs/modules/Administration/views/view.repair.php(55): RepairAndClear->repairAndClearAll(Array, Array, false, true)
#8 /srv/data/web/vhosts/my.url/htdocs/include/MVC/View/SugarView.php(226): ViewRepair->display()
#9 /srv/data/web/vhosts/my.url/htdocs/include/MVC/Controller/SugarController.php(435): SugarView->process()
#10 /srv/data/web/vhosts/my.url/htdocs/include/MVC/Controller/SugarController.php(375): SugarController->processView()
#11 /srv/data/web/vhosts/my.url/htdocs/include/MVC/SugarApplication.php(113): SugarController->execute()
#12 /srv/data/web/vhosts/my.url/htdocs/index.php(52): SugarApplication->execute()

Any idea?

The error seems to be related to Elastic Search, so check your configuration of that. If you’re not using it, you might want to turn it off.

Also check these parameters in config.php:

  • site_url
  • host_name

Thank you for your reply @pgr.

I have no idea how to turn off elastic search, documentation is scarce.

Do you think it’s related to the List View problem?

If you’re having trouble turning off Elastic Search it’s likely because of this bug, which will be fixed in the next version:

It’s always a good idea to clear out any FATAL errors whenever troubleshooting something, even if it doesn’t appear to be related. FATALs interrupt PHP execution, you never know which parts of the code were skipped after a FATAL. Anything can break after a FATAL.

Thanks again @pgr

So, first clear all FATAL… that sure makes sense.

Is my problem a known problem with a solution or should I just try to fix all FATAL and see if it works for my problem?


No , it’s not a known problem.

You might have permissions issues, maybe Studio is having trouble writing out it’s files.

Start by clearing FATALs and then we’ll keep diagnosing from there.

1 Like

I found out,

Actually all the options configured in Studio can be found in the column chooser on the Account List screen.

The Column Chooser is the icon at the right of the Filter icon on the upper part of the list.

Thanks for the help :slight_smile: !


Excellent hint! You saved my day.

Thanks a million,