I cannot find a way to send emails or campaigns using

Is there a plan to fix this?

Thanks in advance for a reply from the SuiteCRM support staff and from anyone who HAS a solution!

Try this settings:
Microsoft Exchange option
Exchange Server:
Port: 587
Activate SMTP over TLS: TLS
uncheck the options to allow other users to use this account

Worked for me. However, at some point it stopped working, and I had to configure a new server (Ubuntu 16/PHP 7), migrate the data (SuiteCRM and DB), in order to make it work again.


Marcelo K

It’s been awhile since I configured Office365 to work with SugarCE, but at the time I did get it working eventually. First, are you positive that you are using the correct SMTP server? Not all MS mail uses this smtp address. Depending on your organization/ mail version you have to log into webmail and get your settings from there (see these steps to get your specific settings if that address is wrong).

I also remember I had to change settings on the 365 side of things as well. I think Office365 has some security settings that block sender impersonation, which Sugar doesn’t like. See this link on changing 365 sender permissions for more info:

If you are still trying to send and not having success, there may be a more descriptive failure message in the log as well. When my send from Office365 wasn’t working at first, there were specific error responses from the SMTP server recorded in the logfile. Those helped narrow down the issue I was having.

I hardcoded the SMTP settings in the smtp class file and now it works.

From the logs, even though the settings were correct, SuiteCRM always connected to the server where SuiteCRM is installed and not to the SMTP server indicated in the settings.

Hi Amariussi,

Would you explain how to do this? I couldn’t get mine working


It’s explained here:

Remember that this is not upgrade safe so do a backup of files and database before you proceed to any changes.

1 Like

Make sure in the email settings the ’ “from” Address’ is the same as the ‘Username’ > you are using TLS > server port is 587

Once you have set all that try a test email and make sure that works and sends correctly

1 Like

Thanks for the reply amariussi & Cameron!
I have tried both method, but just doesn’t work for me unfortunately. I will just use another mail account in the mean time and hopefully there will be an patch for this in the near future…

One more suggestion: (provided you know what you would be doing and you perform a backup before) you can try to edit the email settings directly in the database: you may be able to see things that you may not notice via the standard interface.

Furthermore: have you tried enalbling the logging of the email application within SuiteCRM? It may help you find out what’s happening.

I have had this same issue on SuiteCRM and SugarCRM with Office365.

I eventually gave up trying to use Office 365 for the default SMTP because we just lost confidence in trying. Single emails seemed to work fine but batch notifications would log the connection error.

I suggest using a service that is intended for high scale bulk email. Currently we are using Mailgun because is is free up to 10K emails per month and very cheap beyond that. I have also used and had success with Mandrill and Sendgrid.

Hope that helps

Hi amariussi,

I have tried editing directly from DB. What I think is there might be some blocking within office365 as there’s one log got me concerned. It says…
220 - We do not authorize the use of this system to transport unsolicited, and/or bulk e-mail.


I have basically given up at this stage as well. I am using local CPanel mailbox for now, hopefully there will be patch or tutorial regards to this issue.

Hello guys.
I was able to identify why Office365 email accounts did not work in SuiteCRM.
The error “SMTP Error: Could not authenticate.” happens when the email account is in the KIOSK package, the most basic. You must set up your email account profile as Exchange Online before you can use it with SuiteCRM.

Take a look into these two posts. Hope it helps:

Authenticated SMTP is turned off by default across most tenants and mailboxes in exchange online. This is what SuiteCRM will use to send emails on behalf of an exchange user. To switch this on you can run some basic PowerShell commands, or even easier, follow these steps:

  1. Login to O365 Admin centre and click on ‘Active Users’ Once the panel pops out from the right hand side click on the ‘Mail’ tab.
  2. Under ‘Email Apps’ click ‘Manage Email Apps’ and check the Authenticated SMTP box for each user you want to setup in SuiteCRM.
  3. Your outgoing mails should now work with the default TLS on port 587.

I hope this helps :slight_smile:

1 Like

I wanted to follow up on this issue as this has stumped me for quite some time. Although I had checked the configuration settings on our Office365 tenant over and over again, I was still getting authentication errors connecting to with the correct username and password.

Having spent some time with a Microsoft Engineer this turned out to be a multi-factor authentication issue within Azure Active Directory.

Each user has MFA options in Azure that allow for different types of authentication, we use the Microsoft Authenticator App. However, an app password authentication needs to be added to each user in the office365 portal. And this is what needs to be added as the password in SCRM to connect with TLS. Here are the steps we went through at a 365 user level.

  1. Login to office 365 as the user and go to account settings.
  2. Click on Security info in the users 365 account.
  3. Add authentication method.
  4. choose App Password and create name and password.

Then use this password in the outgoing mail settings of SuiteCRM connecting with the usual smtp server settings via authenticated TLS.

It’s this password the SuiteCRM needs to send mail from that user account. I hope this helps - Enjoy !