"SMTP Error:connect() failed. github.com/PHPMailer/PHPMailer/wiki/Troubleshooting"

I am reposting this post as “new” as I hope to catch the developer attention to the long lasting SMTP issue. I have posted it in another similar topic.

Hi there,

Me too experiencing the same problem. I have installed 5.8 and now I have installed a fresh copy of 7.9.5. Both versions I experienced the same issue.

I am not here to continue complaining about the issue but I hope to provide my findings to allow the developers to look into it and I hope the developer can fix this long lasting issue.

When I setup, with the php-smtp installed on my Centos 7 server, everything went through fine without any issue. When I setup the SMTP for my gmail account, here is what I have found:

  1. I clicked on the “Gmail”, Entered the FROM Name and FROM Address, the SMTP Mail Server, SMTP Port, Use SMTP Authentication and Enable SMTP over SSL or TLS. Then I entered the Username and Password. Followed by “SEND TEST MAIL”. I entered my email ID and click send. It went through without problem and I verified and confirmed I received the test mail in my mail box.

  2. I proceed to Save the settings. Then I went to other tabs and then came back to the Email test by “Admin–>Email Settings”. I repeat the test and I hit the errot “SMTP Error:connect() failed. github.com/PHPMailer/PHPMailer/wiki/Troubleshooting”.

  3. I then click on the password and re-enter the email password and retry the SEND TEST EMAIL. Bingo, the test mail went through.

  4. I get out of the screen and repeat the SEND TEST EMAIL. I noted that the email will go thru without error if I re-enter the password, . If I don’t re-enter the password, I will hit the error.

  5. I tried on “Choose your Email provider Other” and it behaved the same.

In this simple conclusion, my guess is that SuiteCRM email setting does not save the password entered. Therefore, after the email setup, without the password, all the users will hit the “SMTP Error:connect() failed. github.com/PHPMailer/PHPMailer/wiki/Troubleshooting” issue.

I hope my feedback help. Unfortunately, I’m not a programmer and I don’t know how this problem could be fixed.

Thank you.

After an Ubuntu software update, I started getting the same error.

@embee which version of SuiteCRM are you using?

And if you try sending a test email from the email settings, and you get an error, you should see a link to “Show full SMTP log”. What do you have inside that?

I am using v7.8.5. When the error message pops up, it does not show the link for “Show full SMTP Log”.

That’s a very old version, it doesn’t have that “full log” feature yet. :frowning:

Maybe the Ubuntu update left you in a state of some incompatibility, can you try upgrading SuiteCRM?

Meanwhile check your PHP version, see if it fits the Compatibility Matrix.

Ubuntu update did something. That is the only thing changed in the last 1 week. My php, apache requirements etc. all satisfy the Compatibility matrix.

We are exploring the upgrade options as well. But if we can find a solution,