SMTP could not authenticate

So I moved my SuiteCRM install from a Cento6 VPS to a Centos7 vps and SuiteCRM outbound email stopped working.

I searched the forums, there were a lot of posts about this issue but not really any definitive solutions.

I have a plugin on my WordPress site that is also on the new server that has a wonderful SMTP diagnosis feature with solutions! So it recommended I change a setting in WHM.

“Login to CPanel > Tweak Settings > All> “Restrict outgoing SMTP to root, Exim, and mailman (FKA SMTP Tweak) and switch it from “On” to “Off”.”

That seemed to do the trick for me. It immediately started working after I turned this off. Just posting if anyone else runs into this issue. It is “On” by default and you won’t be able to send out emails via SMTP.
One more thing to try! Hope it works for someone else too.

2 Likes