Size of Upload (34004522 bytes) Exceeded Allowed Maximum: 31457280 bytes

im trying to upgrade from version 7.11.13 to 7.11.20
from diagnostic i can see :
my php version is 7.2
Loaded Configuration File: /etc/php/7.2/apache2/php.ini
file_uploads On On
upload_max_filesize 50M 50M

i installed the upgrade patch 1.0.1
i rebooted the server
when trying to upload the upgrade file:
I’m receiving error:
ERROR: There was an error during your upload, please contact an administrator for help.
* Size of Upload (34004522 bytes) Exceeded Allowed Maximum: 31457280 byte


You should change parameter: Admin -> System settings -> Maximum upload size:

1 Like

@p.konetskiy you are right that this is the relevant setting, but changing it there is not effective. it needs to be changed in php.ini.

@do-d search these forums for upload_max_filesize, you’ll find many pages explaining how to do it.

1 Like

@pgr, sorry.
Look at the first post:

Check post_max_size in php.ini

1 Like

Ah, I missed that, you’re right.

Another thing to check is if the correct php.ini is being changed, sometimes the value is changed in the wrong file, or the change didn’t take effect because a web server restart is missing. The best place to check effective values and exact php.ini path is in Admin / Diagnostics / phpinfo.

Also if you guys can go in this PR and leave a “Like” or post asking to get it merged, all the work here in the Forums would be greatly facilitated:

1 Like

Hi , thank you
it was the post_max_size setting

upgrade finished successfully

1 Like