Site broken after upgrade from 7.8.25 to 7.10.13

Upgraded using file: All appeared to go smoothly. I am still logged in and can access the CRM.

However, when I go to the login (index.php) page in a new browser, I get white screen. In the logs, I have this error:

PHP Fatal error:  Uncaught Error: Class 'SuiteCRM\\Utility\\SuiteLogger' not found in /include/utils/recaptcha_utils.php:206\nStack trace:\n#0 /modules/Users/Login.php(163): displayRecaptcha()\n#1 /include/MVC/View/SugarView.php(818): include_once('/home/matt/publ...')\n#2 /include/MVC/View/views/view.classic.php(72): SugarView->includeClassicFile('modules/Users/L...')\n#3 /include/MVC/View/SugarView.php(211): ViewClassic->display()\n#4 /include/MVC/Controller/SugarController.php(435): SugarView->process()\n#5 /include/MVC/Controller/SugarController.php(375): SugarController->processView()\n#6 /include/MVC/SugarA in /include/utils/recaptcha_utils.php on line 206

I have done a Repair and in fact, tried most of the options on the repair screen. I also manually deleted all the files in the /cache folder.

I see the problem is related to recaptcha - is there some way to disable it? Any help, much appreciated.

More info about my set-up:

Ubuntu 16.04
Apache 2.4.18
MySQL 5.7.25
SuiteCRM 7.10.13

The site is on a VPS that I manage. I have full root access including ssh. The CRM has been running for a few years, this problem only started after the upgrade.

The only log messages relevant to the problem is the one I reported above.

I have manually edited the file “include/utils/recaptcha_utils.php”, commenting out line 206 which instantiates the SuiteLogger class. Now the login page loads.

The SuiteLogger is imported via use on line 47:

use SuiteCRM\Utility\SuiteLogger as SuiteLogger;

. Apparently, this is failing for some reason. Is there an autoload file that should be called but isn’t?


Just a me too on this one…

Fatal error: Uncaught Error: Class 'SuiteCRM\Utility\SuiteLogger' not found in /home/pablostevens71/ Stack trace: #0 /home/pablostevens71/ displayRecaptcha() #1 /home/pablostevens71/ include_once('/home/pablostev...') #2 /home/pablostevens71/ SugarView->includeClassicFile('modules/Users/L...') #3 /home/pablostevens71/ ViewClassic->display() #4 /home/pablostevens71/ SugarView->process() #5 /home/pablostevens71/ SugarController->processView() #6 /home/pablostevens71/crm.igosalesandmarketing in /home/pablostevens71/ on line 206

OK so I think I figured it out. In recaptcha_utils.php it references…

use SuiteCRM\Utility\SuiteLogger as SuiteLogger;

On line 47 however that file is not in that directory, its in /lib/utilities/SuiteLogger.php

I tried changing the file reference on line 47 without success so I just moved SuiteLogger.php to:


and all works. Not sure what I’m doing wrong with the file reference on line 47 but changing it to \Utility\SuiteLogger doesn’t seem to work?

BTW I’m on 7.11.2 so this is still an issue.

1 Like

Same error upgrading from 7.10 to 7.11.

Fixed moving SuiteLogger.php