Setup of database breaks

I’m attempting to install SuiteCRM and I get to the page where I enter the database credentials and then click on “Next.” The box pops up saying that it is Verifying DB Credentials and then the box just goes away. Nothing happens, and no error comes up. My web logs show the following:

2017/08/13 00:07:10 [error] 13991#13991: *86161 FastCGI sent in stderr: "PHP message: PHP Notice:  Undefined index: setup_db_type in /var/www/server/html/crm/install/install_utils.php on line 584
PHP message: PHP Notice:  Undefined index: setup_db_manager in /var/www/server/html/crm/install/install_utils.php on line 584
PHP message: PHP Fatal error:  Uncaught Exception: Cannot load DB manager in /var/www/server/html/crm/include/utils.php:1687
Stack trace:
#0 /var/www/server/html/crm/include/database/DBManagerFactory.php(97): sugar_die('Cannot load DB ...')
#1 /var/www/server/html/crm/install/install_utils.php(584): DBManagerFactory::getTypeInstance(NULL, Array)
#2 /var/www/server/html/crm/install/checkDBSettings.php(300): getInstallDbInstance()
#3 /var/www/server/html/crm/install/checkDBSettings.php(50): copyInputsIntoSession()
#4 /var/www/server/html/crm/install.php(329): checkDBSettings()
#5 {main}
  thrown in /var/www/server/html/crm/include/utils.php on line 1687" while reading response header from upstream, client:, server: server, request: "POST /crm/install.php HTTP/1.1", upstream: "fastcgi://unix:/run/php/php7.1-fpm.sock:", host: "server", referrer: "https://server/crm/install.php"

I’m running Debian 8.9, Nginx 1.12.1, PH 7.1

I’ve tried both SuiteCRM 7.8.5 and 7.9.4 and get the same error.

Any thoughts on what is causing this?

I have the same problem

Got the same problem, can not continue instalation

Does this happen with the latest versions of SuiteCRM?

Which database are you using?

Are you all using Nginx?

Thanks for the fast response, I have:

SuiteCRM 7.10
MariaDb 10.1.

I am not using nginx.

Other config:
PHP Version 7.0.27-0+deb9u1
XML Parsing OK
MB Strings Module OK
Writable SuiteCRM Configuration File (config.php) OK
Writeable Custom Directory OK
Writable Modules Sub-Directories and Files OK
Writable Upload Directory OK
Writable Data Sub-Directories OK
Writable Cache Sub-Directories OK
PHP Memory Limit OK (128M)
ZLIB Compression Module OK
ZIP Handling Module OK
PCRE Library OK
IMAP Module OK
cURL Module OK
Upload File Size OK
Sprite Support OK
PHP allows to use stream (upload://) OK
Location of your PHP configuration file (php.ini): /etc/php/7.0/cgi/php.ini

That memory limit strikes me as particularly low, 256 MB would be better, or even 512 MB if possible.

Can you log in to your database with those credentials, using phpMyAdmin or the mysql command-line? (or whatever the equivalents for these are, in mariaDB)

What did you use as host name? Normally it’s “localhost”, if you’re on the same machine.

I changed it to 512 MB and no change.

Yes, I am able to login via “mysql -u username -p” and you are right, I am using ‘localhost’.

Here is the log:

[Sun Feb 25 21:18:54.723402 2018]mod_fcgid: stderr: PHP Notice:  Undefined index: setup_db_type in /var/www/clients/client2/web1/web/crm/install/install_utils.php on line 584, referer: http://xx.x.x.x.x/crm/install.php
[Sun Feb 25 21:18:54.723434 2018] mod_fcgid: stderr: PHP Notice:  Undefined index: setup_db_manager in /var/www/clients/client2/web1/web/crm/install/install_utils.php on line 584, referer: http:///xx.x.x.x.x/crm/install.php
[Sun Feb 25 21:18:54.723442 2018] mod_fcgid: stderr: PHP Fatal error:  Uncaught Exception: Cannot load DB manager in /var/www/clients/client2/web1/web/crm/include/utils.php:1773, referer: http:///xx.x.x.x.x/crm/install.php
[Sun Feb 25 21:18:54.723448 2018] mod_fcgid: stderr: Stack trace:, referer: http:///xx.x.x.x.x/crm/install.php
[Sun Feb 25 21:18:54.723453 2018]mod_fcgid: stderr: #0 /var/www/clients/client2/web1/web/crm/include/database/DBManagerFactory.php(97): sugar_die('Cannot load DB ...'), referer: http:///xx.x.x.x.x/crm/install.php
[Sun Feb 25 21:18:54.723458 2018]  mod_fcgid: stderr: #1 /var/www/clients/client2/web1/web/crm/install/install_utils.php(584): DBManagerFactory::getTypeInstance(NULL, Array), referer: http:///xx.x.x.x.x/crm/install.php
[Sun Feb 25 21:18:54.723463 2018]  mod_fcgid: stderr: #2 /var/www/clients/client2/web1/web/crm/install/checkDBSettings.php(300): getInstallDbInstance(), referer: http:///xx.x.x.x.x/crm/install.php
[Sun Feb 25 21:18:54.723468 2018] mod_fcgid: stderr: #3 /var/www/clients/client2/web1/web/crm/install/checkDBSettings.php(50): copyInputsIntoSession(), referer: http:///xx.x.x.x.x/crm/install.php
[Sun Feb 25 21:18:54.723474 2018] mod_fcgid: stderr: #4 /var/www/clients/client2/web1/web/crm/install.php(327): checkDBSettings(), referer: http:///xx.x.x.x.x/crm/install.php
[Sun Feb 25 21:18:54.723478 2018] mod_fcgid: stderr: #5 {main}, referer: http:///xx.x.x.x.x/crm/install.php
[Sun Feb 25 21:18:54.723483 2018] mod_fcgid: stderr:   thrown in /var/www/clients/client2/web1/web/crm/include/utils.php on line 1773, referer: http:///xx.x.x.x.x/crm/install.php

Something is not right in your system, in the connection between PHP and database.

Sometimes you need to enable database modules in php.ini (or in some checkbox in CPanel if you are in shared hosting).

Search Google for your error along with “php module”