Setting up a workflow

Hello everyone,

I’m setting up a workflow to send automatic emails after 5 or/and 10 days.
I’ve specified my conditions and created a mail template.

But the workflow never starts. Below are the settings :

Thanks for your help.

Go to Admin > System > Scheduler > Setup Crontab.
Check whether you have setup the crontab as described, to run the Schedulers:

In order to run SuiteCRM Schedulers, edit your web server user’s crontab file with this command:
sudo crontab -e -u mywebserverusername
… and add the following line to the crontab file:
* * * * * cd /path/to/suitecrm; php -f cron.php > /dev/null 2>&1

What are your conditions?


Can’t a workflow be created without modifying the cron file?

Workflow needs the Scheduler to be running. For the Scheduler to run, it requires the cron.

More here:

1 Like

Check out my video on the scheduled workflows (which need the cron file to be adjusted) maybe it helps:

That’s basically the only option you’ve got, when it should run completely automatic.
You can double check / configure / activate the schedulers under the URL:
yourcrmdomain/#/schedulers/index (in SuiteCRM 8)

In case, you will do some work / updates after 5 or 10 days on the records and after those updates, the email should be triggered, then you can use a standard workflow, triggered by the updated field / condition.



I modified the crontab file with the command.
After that, I re-tested the workflow but it doesn’t work.

I have read the documentation sent and my apache user has been identified.
Do I need to make any other changes to the crontab file?

Thanks for your help.

Hey Mio, you just have to keep at it until you get the cron job to run. It can be frustrating, I know. On different hosting platforms they syntax to run the cron job can be different. I find there are a few things you have to work on to get it to run:

  1. getting the syntax right, the path to php and the path to cron.php
  2. Memory limit. Often the “server” memory limit for PHP is set independently of the hosting folder. Often the server PHP limit isn’t set high enough.
  3. The server PHP version may be different from the folder PHP version that SuiteCRM runs in.

You’ve just got to keep at it and try different things.