Setting ROLES does not save

Can someone help me…

I have a working system that has many custom modules. Recently I have a problem in ROLES. For some of my modules from a certain point in the list and beyond I can no longer save a change to the roles. I try to change some thing like IMPORT NONE and the screen looks fine but when I save it - it returns to the original value. There is one module and one attribute where this problem starts and is evident in all modules and attributes after it in the list.

Has anyone seen this before? Any assistance would be greatly appreciated.

If you can please try and reproduce this issue in the live demo. This one allows Admin access:

If it also happens there, then you should open an Issue with this on GitHub. It would be nice if you can specify exactly in which row the problem starts.

Also, check if you have any errors in your logs on in your browser’s developer console.

I tried to duplicate on that other system and it works fine. I also tried a couple different THEMES on my system and the problem is the same.

You question regarding which row had me thinking. I looked at two of my systems that are almost the same (Dev and QA) and both have this issue however the installed modules are not exactly the same. The problem with the ROLES is the same but on different modules. What I did discover is that the problem always starts on line 111 of the Module list in roles and then always from the IMPORT setting and beyond. Not sure if that makes a difference.

I can easily open a bug on GIT but was hoping to see if this is really a bug or some data/corruption issue on my system only.

That’s very weird indeed. Can you try examining the page source HTML around that line? There must be something broken that is throwing the rest of the screen off…

I am not an HTML developer so I grabbed a screenshot of the HTML source from my browser. What I did notice is that there is an extra style="" in the HTML exactly where the problem starts but cannot be found again after that point.

Circled in the screenshot.

Here is the HTML instead…

All Not Set None
				                       <div class="aclNot Set" id="48b003ec-6884-642a-03c1-51b73e53d930link" onclick="aclviewer.toggleDisplay('48b003ec-6884-642a-03c1-51b73e53d930')" [b]style=""[/b]>Not Set</div>

Yes, I prefer a copy-paste, not an image.

But please enclose it in the forums’ “code” tags, otherwise some characters will be lost. And paste the whole thing, not just a bit. I’ve already copied this section so I can find it later in the middle of the rest. But having the rest helps to compare.


I keep getting “You have to many links in your message, please decrease it!” when I try to post all the HTML

Did you use the “code” tags?

Anyway, if it’s easier, just use and then give us the link to that.

pastebin was limited to 512k and the file is 1.2Mb.

Here is a link to a Google Drive file instead…


Got it, thanks.

If you go into the browser’s developer console, and edit the HTML, removing that


does it fix the issue?

No - that did not solve the issue.

What is your version of SuiteCRM? and of PHP?

Which theme are you using? Can you try it in SuiteP to see if it works?

Version 7.8.1
Sugar Version 6.5.24 (Build 509)


We use a custom Themes but I can duplicate the issue using Suite P as well.

I don’t know, then. Maybe try a few different Repairs in the Admin / Repair area.

Also try on a different computer, there might be some cache problem.

Finally, if nothing works, consider updating those values through the database via phpMyAdmin or similar. Look for tables whose names include “acl”, “roles” or “actions”.

Good luck!

Hi, All!
Have the same issue. There are more than 120 modules in our system. After a certain field on roles page changes are not saved. Looks like some kind of limitation…

And the solution is very simple - just change variable max_input_vars in php.ini:

; How many GET/POST/COOKIE input variables may be accepted
; max_input_vars = 1000
max_input_vars = 2000

Do not forget to restart Apache

@Barmix I would say that is not the same thing. There was a new bug on Roles which we have fixed, and we are about to release a new version to get that out to everyone.

Your problem looks like a consequence of having an unusually high number of modules in your system. Because of the way those screens are handled, it requires PHP to have higher resources (max_input_vars).

Anyway I am glad you got things working and thanks for sharing the max_input_vars tip!