👋🏾 Looking to join our SuiteCRM Community Working Group? 💌 Open invitation throughout January. Check out all the details here 👈

Set up Gmail inside Suite CRM

My company uses G-Suite for almost everything. I love the flexibility of Suite CRM and would like to use it to allow my employees to send emails directly to contacts. I just can’t get the email system quite figured out.

I have the “System” email in place using my admin@projectoutbox.com email address to send notifications and reminders. But I can’t get the user emails set up to work correctly.

All users are active and ready in G-Suite.
Gmail accounts have been set up.
I added the proper accounts under “outbound email accounts” in Suite CRM
I can send a test email and it works after I enter the user password to authenticate in G-Suite, but it will not work when I save.
When I click on a contact’s email address to send the email, it also says “Authentication failed”.

Not sure what I’m doing incorrectly.

Any advice!??

You might want to give this a try. I haven’t used it with SuiteCRM, but it worked out great for me in WordPress to be able to send through Gsuite.

https://support.google.com/accounts/answer/185833?hl=en

You have to setup an app password that doesn’t require two step verification. If you don’t Authentication will always fail.

This is another method that has worked for me. They keep changing stuff on the Google end, so you can try both methods.

How to Connect Gmail to SuiteCRM

Prerequisites:

  1. You must have and SSL installed on your installation.

  2. Login to gmail, got to settings, ON the Accounts and Import Tab, go to “Other Google Account Settings”. Go to Security and disable the following: 2-step Verification and then Turn “Less Secure App Access” to ON. (if you are using gsuite, you may have to ask your administrator to do this for you).

  3. After you have entered all the connection info and immediately before trying to select the trash folderin SuiteCRM gmail setup dialogue, (you must be logged into gmail in another browser window)go to this URL to disable CAPTCHA temporarily. As SuiteCRM will not be able to process the CAPTCHA. https://accounts.google.com/b/0/DisplayUnlockCaptcha

Incoming Mail (IMAP) Server

imap.gmail.com

Requires SSL: Yes

Port: 993

Outgoing Mail (SMTP) Server

smtp.gmail.com

Requires SSL: Yes

Requires TLS: Yes (if available)

Requires Authentication: Yes

Port for SSL: 465

Port for TLS/STARTTLS: 587

Full Name or Display Name: Your name

Account Name, User name, or Email address: Your full email address Password: Your Gmail password

hello, we have the same problem. all mails from user going to the spam ordner. coult you . Könntest du das Problem lösen? muss mann evtl. bin server oder bei google was einrichten?

Hi @Project_Outbox
Setup Gmail Inside SuiteCRM Setting with a simple Step .
Please follow the link : Create Inbound Gmail Setting
Suggestion: Y ou must be logged into gmail in another browser window ,go to this URL to disable CAPTCHA temporarily.
Here the Video for Inbound setting:- https://youtu.be/wLdjHwgwgZY

Thank You

1 Like