Send marketing email as test and browser hangs for minutes

Created email template and did email test, the email gets sent correctly but the browser suitecrm page hangs for minutes, any idea what could cause that?

That’s unusual. Do you see any messages in the your logs at that precise time?

Nothing in the logs files, but it seems to cause ubuntu apache2 to fork more processes than usual and that seems to degrade server performance. Restarting server apache clears up the system but another email test send causes the same problem.

15337 ? Ss 0:01 /usr/sbin/apache2 -k start
15340 ? S 0:01 /usr/sbin/apache2 -k start
15341 ? S 0:00 /usr/sbin/apache2 -k start
15342 ? S 0:00 /usr/sbin/apache2 -k start
15343 ? S 0:00 /usr/sbin/apache2 -k start
15346 ? S 0:00 /usr/sbin/apache2 -k start
15347 ? S 0:00 /usr/sbin/apache2 -k start
15348 ? S 0:00 /usr/sbin/apache2 -k start
15349 ? S 0:00 /usr/sbin/apache2 -k start
15350 ? S 0:00 /usr/sbin/apache2 -k start
15351 ? S 0:00 /usr/sbin/apache2 -k start
15352 ? S 0:00 /usr/sbin/apache2 -k start
15353 ? S 0:00 /usr/sbin/apache2 -k start
15354 ? S 0:00 /usr/sbin/apache2 -k start
15355 ? S 0:00 /usr/sbin/apache2 -k start

Is your memory_limit in php.ini generous?

memory_limit = 128M

I use 512MB, I’m not starved for memory in my server. If you can give it a higher value, please do.

I am curious if this would impact the performance problem you’re experiencing…

That didn’t make a difference. Same issue after pumping php memory to 512.

Don’t forget to restart Apache!

If that still doesn’t work, and your database is big, or if it’s been running for years, you might want to explore tips from this article:

I did restart apache, it is small database, and just started using suitecrm couple of months ago on new ubuntu machine that meets suitecrm requirements.

I don’t know, then.

Maybe you can try to investigate from the browser side, developer tools, try to profile that delay…

click on filter cancel X seems to hang too.

All I can say is that that is very unusual, but only you can investigate locally…

The filter case shows it’s some problem with your computer or network, because SuiteCRM is really not running much code there, there is no reason to hang.

Try a different browser, try from a different computer, try from the local network where the database is, etc.

It doesn’t hang if I try it from Microsoft Windows machine using any browser. It hangs if I try it from any browser on MacOS machine or IOS device.

It is strange, because that sounds like Javascript problem, but Javascript is basically dependent only on the browser, so it shouldn’t be exactly the same problem when you switch browsers… and still, only you seem to be getting that problem.

Maybe try a different Mac. It could be some anti-virus problem?

I tried it on different Mac Book and on Apple ipad, same issue.