Security Group not inherit from parent record

Hello all,

I have created a few custom modules:


The Application module has many to many relationship to Application_Customer and Application_product.

When a new application is created, then i need to add a record in application_customer sub-panel and application_product subpanel.

I suppose all three records should have the parent group (assigned user’s group) inherited.

But the assigned user is not able to see any record in sub-panel, neither does the group leader.

Any suggestion?


You have to make sure Roles are properly configured on those new modules. If for any reason the new modules are not display under Roles, go to Admin->Repair->Repair Roles.



I know this is an old thread, but I’m having the same issue. I created a custom module “Buildings” and a Security Group “A” When I create an account, contact, etc. with a user in “A” the record gets added to the security Group “A”. In my custom module Buildings to not get added to the security group???

I don’t use security groups all that often, so just wondering if I missed something in creating the module? I tried the repair roles as suggested above and that didn’t make a difference.

Anyone have any ideas for me to try?

You might need to add a workflow or a logic hook to take care of that. Security Groups tends to be very sensible and likes to make things difficult sometimes :slight_smile:

Thanks @BrozTechnologies I eventually solved it. I forgot to close the loop on this thread. Here is a link to the solution I posted on another thread.

1 Like