Make a quick vote 🗳 ️How do you refer to SuiteCRM extensions: add-ons or plug-ins? Click here to have your say 👈

Scheduler URL dropdown menu is blank

Hi, I am a newbie on suitecrm and looking for some help iin setting up my first cronjob.

Problem is that when I review the process workflow schedule the job url option is blank an there is some test indicating some kind of error.

Strict Standards: Declaration of SugarFieldTime::save() should be compatible with SugarFieldBase::save(&$bean, $params, $field, $properties, $prefix = ‘’) in /home/readafri/public_html/suitecrm/include/SugarFields/Fields/Time/SugarFieldTime.php on line 95

Does your SuiteCRM have a version number? :slight_smile:

Thanks for your reply.

The version is

Version 7.9.8
Sugar Version 6.5.25 (Build 344)

Can you update it to the latest 7.9.x? I believe your issue has already been fixed a few versions ago.

Ok. Let me try and upgrade and see what happens. Thanks

Hi,

I succeeded in making a clone site, upgraded the suitecrm and now the URLs are showing. Thanks a lot.

Now I want to do a test to see if my scheduler option is working for my workflow task. I created a workflow task for an email to be sent to me if a record had a specific condition. I chose on scheduler only and I assumed it will use the workflow scheduler which is set at every minute. I expected to get many email records by selecting the ‘scheduler option only’ but I got no email. I have created the cron on the cpanel cron jobs section as directed on the suitecrm.

Can you help please or direct me to a link that can walk me through this process on how to set it up correctly in case I am missing something. Please

There are several ways to check if your cron jobs are actually running, from Linux. You can also go inside SuiteCRM, Admin / Schedulers, click the Workflow process and see the “Last ran successfully” field: is it recent? Is it in the correct timezone?

Then, if you conclude the Scheduler job is running, you might need to debug your specific Workflow to see if the conditions are well designed, if the options are correct, etc.

See
https://docs.suitecrm.com/user/advanced-modules/workflow/

the initial section explains in some detail what the options mean, and how they combine.

If you can’t get it right please list the exact options you’re using (all of them), the exact condition, etc., and I can try to help.

Hi, Last successsful run: Never.

Can I give you the login to the clone site you take a quick look please?

I have uploaded somescreen shots of the settings I have used on wetransfer.

https://wetransfer.com/downloads/1dc5acb178302d30b09515a5a614e8d620181103174001/43c0ae4c657b19f65be820f5ae3fc5de20181103174001/985287

Thanks for the help

Sorry, I don’t do “logging in” jobs except when payed for it, and right now I’m not taking any offers.

Let’s focus only on getting your jobs to run - only when that “never” goes away, you have any chance of getting your Workflow operational.

I suspect that the PHP executable isn’t defined in the server’s PATH, so it is being found. Your hosting should be able to assist you with this, but you can also try a few things for yourself, if you prefer:

If you have SSH access, type this to get your PHP path:

php -i | grep  '_ ='

Now use this path in your cron command, change the part that says

php -f cron.php

to this:

/usr/bin/php -f cron.php

(or whatever was the path you got)

You can also check your syslog to see if there are any other messages about having trouble running your cron command.

Hi,

Thanks for the support you are giving me.

I accessed ssh using putty and typed php -i | grep ‘_ =’

I got a blank response (see screen shot)

I then decided to use the default option given in the example on cpanel as the path (See attachment)

I now got an error email in my inbox every minute (see attachment) :frowning:

I have put up the screen shots in wetransfer

https://wetransfer.com/downloads/84755fe98958441be0ae91c8fa5ff33720181105133036/a8b6cdb013e0031e50ed44fc1474df4a20181105133036/2c3bfc

3 files

The correct command is


cd /home/africamed/public_html/crm/suitecrm; /usr/local/bin/ea-php71/php -f cron.php > /dev/null 2>&1

or, if that doesn’t work,


cd /home/africamed/public_html/crm/suitecrm; /usr/local/bin/ea-php71 -f cron.php > /dev/null 2>&1

Its working! Thanks a million! :slight_smile: