Save record, blank screen returns to http://localhost/SuiteCRM/index.php

Everytime I edit and save a record from accounts or contacts, I get a blank screen with the url: http://localhost/SuiteCRM/index.php

I have done a quick rebuild, repaired relationships and roles but the issue persists. I have been having issues in the past wrt permissions, but for the most part, everything seems to be working.

I am using Version 7.11.8, Sugar Version 6.5.25 (Build 344), installed locally on a Mac.

Any suggestions are appreciated.



Blank screens normally leave a FATAL error in your web server log (the one defined in your php.ini)

Also, are you actually running this on localhost? Or did you just forget to set (during installation) the values that go into config.php, called site_url and host_name?

Site was installed local and is ‘site_url’ => ‘http://localhost/SuiteCRM’, correctly assigned in config.

Re php.ini I can’t seem to find this at all. Where does this normally reside? Even with a search I cannot find it. Strange

In Admin / Diagnostics / phpinfo you can see your php.ini path. It’s important that you know this. while you’re looking at phpinfo, you can check your error log location also.

Did you change your .htaccess file in any way?

You can try if this change corrects your issue:

Run a Admin / Repairs / Rebuild htaccess file after editing that.

Not sure if related to your issue but I solved a similar one by enabling iconv extension on the PHP configuration file.

More on the iconv extension here:



Okay I found this and see a nice summary of my php settings etc. So, for this htaccess file, are you suggesting I replace it?

The easiest thing is to wait for the next SuiteCRM version, which is imminent.

But if you want to apply that patch manually, you change the file mentioned there, and then run Admin / Repairs / Rebuild htaccess.

The file is called


and the full contents after changed should be this: