SAML authentication between G suite and suitecrm not working

HI dear,
After upgrading to latest version my SAML authentication between G suite and SuiteCRM not working. i even installed fresh station there is also not working. Is it no more available in suiteCRM ?

I’d really appreciate a short or long introduction to how to use SAML at all? We also use Google and it would be great to allow single signon via google.

Was there any ever resolution to this? Not having SAML working with Google is a blocker for us moving forward. Thanks, all.

we are using the suiteCRM version 7.8.6 and, after some fix, now the SAML authentication with GSuite works fine!

In particular we had to update to the newest php-saml library.

you can download it here:

(in our case we have used the version v2.11.0)

and substitute it in the following path

The issue is described here:
and here:

Moreover be careful with the “Entity id” field in the Service Provider Details window. ( see “ACS URL” and “Entity ID” must be the same and with this format.

“ACS URL” = “https://<your_suitecrm_path/index.php?action=Login&module=Users”
“Entity ID” = “https://<your_suitecrm_path/index.php?action=Login&module=Users”

At the last, after the activation of SAML authentication. we could needed to logged in with first administration user.
Try adding the parameter no_saml in the suitecrm url .


I hope this can help someone.


1 Like