Safari error when module downloads


I tried to install the french module translation but failed. I go to and download the module by clicking on the cloud logo (download or upload) but it’s not a zip file. How can i do ?

Thank’s a lot.

Its not a zip file?

I can get a zip file, see pic:

In fact when you download file from Safari it doesn’t generate a zip file. I tried whith Chrom and it worked.

Thank’s a lot.

tested with safari and it worked fine.
Maybe it was a temporary issue from Crowdin or from your side.

Note: please help translate the remaining lines!

I uploaded the .zip File on SuiteCRM website support. But i can’t use it. The module loader don’t accept the uploading of this file. I m working on Mac OS, with SuiteCRM on a localhost on my mac
Someone has an idea to solve it ?

If you have downloaded the translation with Safari, Safari automatically unzips the file and place the zip file in your trash folder.
Make sure you upload the zip file rather than trying to upload a folder.