Restrict access to leads for employees except assigned leads

How to restrict access to leads for employees except the leads that these employees have been assigned by the Admin ? all other leads must not be visible by these employees

i do not understand why it does not work :

I have an employee (super admin) and 2 assistants (i put them in a security group for which I deactivated leads access)

My questions are:

why do I still see the leads in the employee account knowing that i disabled access to the security Group in which this emplyee is

how can i make only assigned leads only appear to this employee and not the others ?

When I assign leads in the group from the Super Admin, why the lead user name still appear as “super admin” as it should be the assistant name

Thanks you so much if someone can explain me the clear steps!

There are 3 sides to security:

  • user and groups they belong to
  • roles
  • assigning records to security groups

My advice is to set up this “typical” scenario exactly like it is described here, and once it is working, and you have played with it and understand it, then change it to fit your needs.


thanks but it does not work and im unable to do what I want. im now wasting almost a week on this issue. I have even followed exactly what was described here:

and im still able to view the leads from the employee account eventhough I created a new role, assigned my employee to that role, and disabled access to leads. why am i still able to view the leads from my employee account ??

Did you go in the Leads’ records, scroll down to the bottom, and assign the correct security groups to them?

You can also “Mass assign” from the List view.

I thanks I did what u said, it worked, and I wasnt able to access the leads from my employee account. the problem is that what i want to do is that i want to give access to this employee, only certain leads and not others. so how do i do that ?

i also tried to re activate the access to leads and all leads actions for that role and i cant re access the leads anymore. did i miss something again?

can u please explain why i cannot reactivate access to my employee? despite having the employee role access set to everything ! it drives me crazy

Hi. Sorry, just back from holidays.

As I wrote above

So you need to check all those things, not just one or two. Sometimes it’s tricky to get things right.

Normally it’s the 3rd one that everybody neglects.