Required File System Permissions on Windows With WAMPSERVER

Hello everyone

I want to know how can i change File System Permissions on Windows With wampserver ??

Infos : SuiteCRM 7.1.5

The simple answer is you don’t, and you don’t need to. And here is why…

Apache already has all the permissions it needs, as it runs under the LocalSystem account on Windows, which has extensive read/write access to local paths. This is inherited by PHP.

For example, when you are upload a file , Suite already has the needed permissions to be able to create a new sub-folder in the uploads folder, and move that file in from the temporary folder. No file permission changes are needed. No php.ini edits are needed.

If there is a Problem,

  • The additional file permissions that have been set up afterwards are at fault (check Windows Event viewer).
  • Settings have been wrongly edited
  • The Apache Service ‘Log On’ account has been switched from “LocalSystem” to something else (check Service’s Properties).
  • Or there are internal PHP errors (check the website’s HTTP and PHP error logs).

If you really really need to run chmod (read/write permissions) and chown (ownership) for some reason, there are some Windows equivalents and ports of these Linux commands that you can download, that just take the number, re-interpret it, and then use Windows native methods and commands to set the permissions…

But Apache, for the most part, already has full read and write permissions in the WAMP folder, so there is nothing that needs changing, unless you are trying to set lesser permissions.

You can even use a PHP script to do this, as PHP has chmod() and chown() functions…

-> Aside form that, to set file-permissions under Windows, using Windows native ways, you can right-click any folder or file, go to Properties, Security, and set the permissions there. Or use any number of command-line utilities…

-> Check settings in Config.php and utils.php - MySQL settings shoud be empty ’ ’ for User/Group

because I have a problem

When loading a page, the following message : " undifined "

Same thing when validating an suppression, the following message popup appear
The page at " http://xxxxx:8080/suitecrm says: undefined1undefined "

and searching on the net, I found that to solve this problem we had to change permission on the cache folder

Is this your Main Installation or a Clone?

In fact, it is a project that has been developed by another person, and I have to copy the project folder and I have rename,and I work on it
But this problem there is not present when I was working in localhost

by cons in the properties of the file cache, the box is checked and enabled