Request Entity Too Large

When attempting an upgrade from 7.10.2 to 7.10.3, I am getting the above message as soon as I attempt to upload the upgrade package. For wwhat it is worth, I have already changed post+max_size and upload_max_filesize to 64M in php.ini and restarted php-fpm and httpd

I never heard of this error before, but a quick Google tells me sometimes it’s a browser problem. Can you try a different browser to see if it works?

Sorry, firefox is the only browser available to me at present, though I will try to make time to get an alternative installed. But what I have just done, to make sure the problem could not have been due to me altering any php or apache settings in between releases, is to clone a working 7.10.1 SuiteCRM instance, upgrade it to 7.10.2 without any problems, and immediately follow this by attempting the upgrade to 7.10.3, whereupon I got exactly the same “Request Entity Too Large” error as before.

Another thing you can try is to clear the directory “upload/upgrades” and to try re-downloading the upgrade pack, sometimes these issues are due to are corrupted files.

Yes - just tried that. The zip file had the same checksum as last time, and the upgrade failed as before.

Problem solved - the offending parameter is in the apache security module (on Fedora in the file /etc/htt/conf.d/mod_security.conf). Have changed SecRequestBodyLimit from 13107200 to 32000000.

Maybe worth publicising this more widely as the solution is not likely to be intuitive to people other than hardcore web gurus.

1 Like

Guess what is the first link people will get in Google when trying to solve this problem?

There, it’s publicized :slight_smile: