Reports - Group By not working properly

If I create a report and choose ‘groupBy’ it is hit or miss if it works properly.

My Product Line is the field and as you can see it doubles up on two of them.

I checked the database (Distinct) on my fields to ensure that there are only 4 types (Product Line)

I get various results but the one below is most consistent:

Version 7.11.12

Any ideas?


The problem was with two entries in the DB. The currency ID field was blank for some reason. Once i changed them to NULL the problem solved itself.

So ‘groupBy’ does not ‘groupBy’ one field but by many fields?!?!? I choose ‘groupBy’ ProductLine NOT by currency?!?!


You’d have to check the actual DB queries that the Reports module is producing, these should appear in your logs if you’re set to debug level.

What file generates these Queries?

I don’t know, but I can try helping you find out if you give me a sample query, along with the Report that generates it.

Thank you for the offer. I think I got it sorted.

Hello johnwreford.
I’m also facing same issue. can you plz explain how you solved this?