Reports don't show any results


I created a simple report, here is a screenshot of it:

When I save the report I expected it to contain one result row (there is one account in the system which matches the report criteria) but it remains empty. I tried it with other criteria (e.g. Contacs Birthday > Equal To > Date > Today) but again no result.

Is there anything I am missing?



I am so sorry but I have to push this to the top. A CRM system without reports is of very limited use. :slight_smile:

Am I really the only one experiencing this? I was sure I read the documentation conscientiously, but maybe I have missed something. Do (standard - not scheduled) reports require any cron jobs or something like that?

Any help is really appreciated. :slight_smile:


I just started using suite crm a couple of weeks ago and I found it difficult to get the exact parameter for report display. Could u provide a little more detail on the record that u exected on the report?

I hope u understand the concept of relations. Thats what connects the different modules together

Hi @jmathew,

For testing purposes I created a very simple report which has only one condition: a list of all account names where the account’s type is “Customer”. I guess it is easy because no relationships to any other entity is involved and the condition is a list value instead of test/wildcard/etc. Here is the configuration:

The result when I save the report: no records are displayed. Only when I remove the condition, the reports contains records.

I just recognized that I have tons of “(Run Report Generation Scheduled Tasks) failed in CRON run” errors… does it have anything to do with it?


I tried to investigate it further:

The “(Run Report Generation Scheduled Tasks) failed in CRON run” error has something to do with permissions, but nothing with my original problem that my report contains no data.

I tried to debug it via the log. For me it looks OK: the report gets selected, the report fields and the report conditions. One thing that I find strange: I can’t see the SQL code where the report actually gets executed. But I also can’t find this when I create/execute a report without conditions which works.

Summary: When I create a report with conditions, I receive no records. When I remove the conditions from the report, the report shows record.

Any further idea?

sorry for the delay! I took a look at your screen shot and you seem to be search for customers in the accounts module. I’m not sure how to do this because a customer is an account with a specific contact who has received an invoice from us. So maybe you should be looking for: if an invoice is sent to an account. This would be my guess

How would you find an account is a customer or not