Report module link is not working

Report module link is not working it shows an error "Error retrieving record. This record may be deleted or you may not be authorized to view it."any suggestion Please.


What version of SuiteCRM are you trying this on?

I tried it on 7.5.3 and it appears to work as expected there.

I am using Version 7.5.1

Also not working in 7.6.4
Is there any solution?

Hi All,

I had raised this issue on github here:

I wanted to alert you all to inform that this issue appears to have been resolved in the most recent versions of SuiteCRM!

Please feel free to upgrade and confirm.

Hi John,

it is only partially fixed in 7.7.4. It works now in a Contacts report for an email address, but is still not working for the name of an Account.


Thanks for getting back to me!

Would you be able to give us a little more info on how you achieved this ?

(i.e, what your report consists of in terms of Conditions/Actions)

Okay John, I attached a few screenshots that should make clear what the case is (although it’s in dutch), field and conditions.
Links are set for Account and Contact in a report (module Contacts) and the 2 small screenshots are on a mouse-over on the link, in which it’s clear there’s no GUID on the Account link.

I hope this helps.

Kr Jaap


I believe I have, at least somewhat, replicated your report conditions here, but i’m unable to replicate the issue im afraid.

The report seems to generate links to the Accounts / Contacts as expected.

If you haven’t already run a Quick Repair and Rebuild since upgrading to 7.7.4, I’d recommend running this.
I would also recommend running a “Repair JS Groupings”

It may also be worth re-setting the permissions on your instance, to mitigate any possible issues there.

Hi john,

I followed all your instructions and suggestions, but without any improvement.
I than downloaded the latest version of SuiteCRM from Bitnami and installed it on my laptop.
I changed the file settings to 1517 and 420 ( I still don’t understand why all distributions have the wrong settings)
I created 2 Accounts with a type ‘customer’, each with 2 contacts and create exactly the same report as in my production version.
I’m sorry to inform you that I get exactly the same results (empty GUID in the link) as in my production version. See attached the mouse over of the Accounts link.


Thanks for the update!

After a bit of testing, I think i’ve been able to replicate it.

It seems like the link isnt generated if the Contacts : Account field is the FIRST one in the report.

For the sake of confirming this, could you possibly re-order your fields, so that the Contact : Account field is not the FIRST one?

(Anything else can be the first one, such as Contact - First name, as long as its not the one that has the “Contact : Account” relationship)

Yes after reordering the fields as recommended, it works fine.


Thanks for confirming.

You may wish to try upgrading to the most recent version, 7.7.6, to see if this is resolved. (As I believe there were a few report fixes in this version.)
If not, you may wish to raise this on our Github Repo for a developer to investigate and work towards a proper fix for this.

Please feel free to log it on our Github Repo here: