Remove comma displayed for an integer field

We created a new integer field. When the field value is over 1000, it displays the value with comma as thousand separator. Where do can we change this behaviour so that 12345 is NOT displayed as 12,345 on the list and edit view ?

We also marked “disable format” on the field parameter but it still shows values with comma

Do you check at the below? :thinking:

Admin → System → Locale

Thanks. We checked but the settings is only for currency and no other settings available for integer type fields