Related Field Auto Complete

Hello all,

I have added a custom related field to the opportunities module that is related to users. I am passing an initial_filter to it and that works great as long as the user clicks the arrow. The problem we are seeing is if they start typing in the field, the auto complete is ignoring the initial_filter.

Is there a way around this?


I’d love a way of doing this

Problem is that the auto complete is handled by modules/Home/QuickSearch.php which is called via ajax

The initial filters aren’t passed it to it by the ajax call so it can’t filter by them

1 Like

That’s what I was afraid of. So the next question is, can the auto complete be turned off at the field level?

You could create a custom Sugarfield by copying the standard relate field then edit it to remove the auto complete

I think the code you need to remove is class=“sqsEnabled”

Thanks. I will give that a shot.

Hello digitalmcgrath,
Is this work for you?