Quick repair not working - disaster recovery

Ohh no,
I found myself in a right mess.

Having checked several backups worked well, i deleted older ones… but somewhere along the line an error has crept in and quick repair is no longer working! everything gets screwed up if i run it.

for example i have a number of files in custom/Extension/application/Ext/TableDictionary, that have been saved into custom/application/Ext/TableDictionary folder. But this folder is empty after running quick repair!

I think the error log shows that quick repair is failing with the following error:

I’m losing the battle :frowning:

Tue Jan 10 22:43:43 2023 [864][1][WARN] SugarBean constructor error: Object has not fields in dictionary. Object name was: Audit
Tue Jan 10 22:43:43 2023 [864][1][WARN] Audit::populateDefaultValues $field_defs should be an array

i managed to fix this by installing a new version of 7.12.5 on a fresh server, and pointing it to the old database - then gradually copying over the customization for each module from the old server.

1 Like