Query limit of 20000 reached for Calendar module

Today I am getting this error while logged in as a normal user.
When logging in as the admin user I do not get this error.

This error is only showing up when I I open up shared Views.
Currently I only have 392 records in the meetings table.

Why would this error show up for a normal user verses the admin user?


There’s a setting you can change for this, search these forums for the exact error message and you will find it.

Different users can have different amounts of data, and it might be the case that each record is generating a separate query, I don’t know. Maybe the screen is calling the database once per every calendar item shown.

@pgr, Do you have any recommendations on how much memory, and processor power I should be running on Suite CRM server?

Not really, I don’t have that much experience with enterprise workloads.

I would just try to profile my performance issues, solve the basic stuff first (overgrown tables, basic php settings) and then look into some database optimization, and then throw hardware at my problems :slight_smile:

… unless more hardware is actually a cheap thing, as would be the case with a local server. And even when you’re renting cloud space, if you have many users and a lot of business going through that server, the extra RAM shouldn’t really be an issue.

There are more queries for a normal user than an admin user.
For normal users, additional queries are executed to check access rights with roles and possibly security groups


I suggest also running the first query in this post:

Often you find the root of your performance problems in some overgrown tables. SuiteCRM requires some manual database maintenance for big (or long-running installations).

Found my problem.

I had modified the file include/utils/activity_utils.php to include fields from cstm tables but forgot to add the table in the WHERE statement. This is what caused so many records from being returned. Adding the cstm table to the WHERE statement fixed the problem.

But since this is not a file that should be customized, I restored the file to its original and all is well.

1 Like