Project template workflow error

Hello all,

I’ve been trying to create a workflow that creates a project based on an opportunity, but i encounter an error whenever i try to add a project template, i tried separating them where one workflow creates the project (which works perfectly fine) and the other populates the project with the template (website crashes [http error 500]).

Thank you.

Check your both your logs, the answer should be there.


sorry for the late response, the problem has been solved on the live version so i did not dedicate much time to it even though it’s still present on the local installation.

i found the error in the php logs and thought i should let know, but i’m not sure if it’s a bug or caused by a faulty installation.

“Uncaught Error: call to a member function add() " on null in /var/www/html/suitecrm/modules/project/project.php:553\nStack trace:\n#0 /var/www/html/suitecrm/modules/AOW_Actions/actions/actionCreateRecord.php(406): project->save()\n#1 /var/www/html/suitecrm/modules/AOW_Actions/actions/actionCreateRecord.php(169): actionCreateRecord->set_record()\n#2 /var/www/html/suitecrm/modules/AOW_Workflow.php(963): actionCreateRecord->run_action()\n#3 /var/www/html/suitecrm/modules/AOW_Workflow/AOWWorkflow.php(228): AOW_Workflow->run_action()\n#4 /var/www/html/suitecrm/utils/LogicHook.php272: AOW_WorkFlow->run_bean_flows()\n#5 /var/www/html/suitecrm/utils/LogicHook.php(213): LogicHook->process_hooks()\n#6 /var/www/html/suitecrm/data/SugarBean.php(3112): LogicHook->call_custom_logic()\n#7 /var/www/html/suitecrm/data/SugarBean.php(2428): SugarBean->call_custom_logic()\n#8 /var/www/html/suitecrm/include/SugarObjects/templates/company/Company.php(119): SugarBean->save()\n#9 /var/www/html/suitecrm/modules/Ac in /var/www/html/suitecrm/modules/Project/Project.php pn line 553, referer:

From a quick glance at the code, it seems the project creation is failing because the Project template does not have any users associated with it.

no i’ve made sure to populate all fields still doesn’t work

edit: the template works when added to a project manually but not when it’s done through the workflow

I don’t know, then… maybe there’s something about the relationship of the project to the template that doesn’t play well with Workflows.

You might be forced to go for a Logic hook where you can have more control about what’s happening.

1 Like