Produkte - neues Feld bei Produkteart

Hallo miteinander

Wir haben bei den Produkten drei Masseinheiten:

Produkte Stück
Arbeit Stunde
Produkte Meter

Nun möchte ich die bestehenden umbenennen und auch das neue hinzufügen, das würde tiptop gehen, wenn nicht beim speichern die Beigefügt Fehlermeldung käme. Mache ich etwas falsch?
Vielen Dank für die Hilfe.

Viele Grüsse
Claudia

Hi,
normalerweise hängen die undefined-Labels mit fehlerhaften/unvollständigen Dateiberechtigungen zusammen. Diese erneut setzen, dann mit strg+F5 die Seite neu laden.

Hi,

Das habe ich gemacht, aber die Fehlermeldung bleibt, hier nochmals ein Printscreen wie ich es mache, ev. mache ich ja was falsch?!
Vielen Dank für die schnelle Antwort, ich hoffe, Du kannst mir helfen!
Wie gesagt, ich fülle aus, will die neue Produktart einfüllen, aber wenn ich es speichern möchte kommt immer die Fehlermeldung undefined.
Viele Grüsse
Claudia

Hallo…

hast du vielleicht nach der Installation von Suite diese nochmal in einen anderen Ordner verschoben?

Versuche mal die .htaccess Datei neu aufzubauen

Admin/Verwaltung - Reparieren - .htaccess neu aufbauen.

mfg
Lars

Hallo Lars

Ich habe nichts verschoben und Deine Idee hat leider nicht geholfen, immer noch dasselbe. Gibt es noch andere Möglichkeiten?
Vielen Dank und Gruss
Claudia

Hi,
für zur Sicherheit noch mal diese Schritte der Installation aus:

  
  cd dein/installations/ordner
  sudo chown -R www-data:www-data .
  sudo chmod -R 755 .
  sudo chmod -R 775 cache custom modules themes data upload
  sudo chmod 775 config_override.php 2>/dev/null

Anstelle von www-data muss ggf. ein anderer Owner/Group verwendet werden, das lässt sich nicht pauschal beantworten und hängt von der lokalen Konfiguration ab.

Anschließend wäre noch eine Idee im Admin-Backend alle Reparaturen im JS-Kontext auszuführen und zu testen.

Hallo

Jetzt bin ich etwas überfordert, ich weiss zwar dass man über die chmod gewisse Berechtigungen steuern kann, aber ich habe das suitecrm mit oneclick-Installation bei meinem Hoster gemacht.

Hat es da irgendwo ein Anleitung, wie ich das jetzt machen sollte?
vielen Dank und sorry, ich bin neu hier;-)

Gruss
Claudia

Hast du einen SSH-Zugang auf den Server?

Falls nein wird dir vermutlich nicht viel übrig bleiben außer den Betreiber zu bitten seine Installationsroutinen mit der Anleitung abzugleichen.

Hallo

Nein den habe ich nicht, könnte ihn aber ev. beantragen. FTP nützt da nichts, nehme ich an, oder?

Also müsste ich den Hoster fragen ob er eben diese Installationsroutinen mit der Anleitung abgleicht, oder?

Ich weiss einfach dass ich diese CHmod Einstellungen auf dem Server pro Datei oder sogar Ordner ändern könnte, nützt das was?

Viele Grüsse
Claudia

Das ganze müsste auch per FTP gehen, ist aber mühsam (das rekursive Setzen der Berechtigung dauert), per SSH hast du es schneller umgesetzt & geprüft.

Ich wollte jetzt nochmals etwas anderes ergänzen, dann kommt diese Fehlermeldung, bei der man einen ganze Menge Code in die config_override.php reinkopieren muss.
Am Anfang steht aber noch folgendes:

Possible Cross Site Request Forgery (XSRF) Attack Detected
If you think this is a mistake please ask your administrator to add the following site to the acceptable referer list
harisberger.ch
Click here for directions to add this site to the acceptable referer list

Ich nehme mal an, dass das einen Zusammenhang mit den Berechtigungen hat. Und wo finde ich diese acceptable referer list?

Ich glaube ich muss doch mal die Anleitung durchlesen oder, nützt das was und die gibts glaube ich nur in englisch, bin zwar ziemlich gut mit Englisch aber Deutsch wäre es einfacher…

Vielen Dank für Deine Hilfe und Geduld.
Claudia

Der Code, der dir angezeigt wird, ist eine Zeile die optional in die config_override.php eingefügt werden kann. Sie unterdrückt die Warnung für genau diese Abruf-Konstellation (im Beispiel schlägt die Meldung vor, “harisberger.ch” auf die akzeptierte Liste zu setzen).

Das klingt weniger nach einem Dateiberechtigungsproblem, eher nach Apache/allg. Konfiguration des Webservers.

Hallo

Nun bin ich einen Schritt weiter, es speichert und sagt auch, dass erfolgreich gespeichert wurde, aber wenn ich ein neues Produkt erstellen möchte, hat es immer nur noch zwei Produktearten, mache ich ev. etwas falsch oder muss ich noch irgendwie den Cache leeren?

ich habe wie man im Printscreen sieht Meter hinzugefügt.

Vielen Dank für die Rückmeldung.

Viele Grüsse Claudia

Hi,
leider ist nur ein Screenshot abrufbar, aber der zweite sieht schon unvollständig aus (der Standardwert beinhaltet die neue Option nicht). Daher hier kurz das Vorgehen vollständig beschrieben:

  1. Im Studio das Modul Produkte auswählen, dann Bereich Felder, dann Feld “Type” anklicken. Unter “dropdown list” “bearbeiten” auswählen.
  2. Nun ist die Liste der verfügbaren Optionen sichtbar. Es wird “Meter” mit Kürzel “m” hinzugefügt:

  1. Anlage der neuen Option:
    bei 1) m eintragen, bei 2) Meter. Dann auf “add” (3) und anschließend “save” (4) klicken.

  2. Du befindest dich wieder im Dialog zur Bearbeitung des Felds.

  • unter Standardwert sollte deine Option sichtbar sein
  • mit “save” bestätigen
  1. Option ist in der Oberfläche verfügbar:

Wenn das Vorgehen so nicht klappt, würde ich darauf tippen dass das CRM keine Schreibberechtigungen an allen benötigten Stellen hat.

Hallo

Genauso habe ich es gemacht, auch schon vorher mit dem gleichen Resultat, es sagt zwar es ist gespeichert aber es wird nicht angezeigt.

Ich habe zuerst gedacht, ich mache was falsch aber anscheinend nicht, ev. hast Du noch eine andere idee, was da falsch läuft?

Vielen Dank und viele Grüsse

Claudia

Hi,
wie gesagt, mein erster Gedanke ist, dass im Dateisystem bestimmte Schreibrechte fehlen, die Änderungen also nicht persistiert werden können.

Andere Ursachen würden mir auch einfallen, sind aber eher unwahrscheinlich (Konflikte mit bereits vorhandenem Customizing, z.B. durch Addons aus dem Store, oder Konflikte, die durch Studioimporte/-exporte entstehen könnten).

Hallo

Also dass ich zB. die Berechtigung habe auf die Feld zuzugreifen, aber es sie nicht speichert, weil ein übergeordneter Prozess noch nicht freigegeben wurde?

wie schaffe ich es, das Ganze suite CRM freizuschalten? Oder geht das nur Schritt für Schritt, wo finde ich da eine Anleitung, ich bin ganz am Anfang und möchte nicht ständig blöd fragen, bin nicht zu faul zum lesen, aber halt eben noch nicht so erfahren.

Vielen Dank für die Hilfe.
Gruss
Claudia

Hi,
für viele Änderungen legt das CRM neue Dateien an oder überschreibt existierende Dateien. Wenn der hinterlegte Nutzer des Apache genau dies nicht darf, können solche Fehler auftreten.

Die komplette Installationsanleitung findest du hier:
https://docs.suitecrm.com/admin/installation-guide/downloading-installing/

Hallo

Der Hoster hat für mich folgendes noch umgesetzt:

Führe zur Sicherheit noch mal diese Schritte der Installation aus:

cd dein/installations/ordner
sudo chown -R www-data:www-data .
sudo chmod -R 755 .
sudo chmod -R 775 cache custom modules themes data upload
sudo chmod 775 config_override.php 2>/dev/null

Anstelle von www-data muss ggf. ein anderer Owner/Group verwendet werden, das lässt sich nicht pauschal beantworten und hängt von der lokalen Konfiguration ab.

Er hat mir dann folgendes mitgeteilt.

Eine Owner/Group gibt es nicht.
Den Rest habe ich umgesetzt. Bitte versuchen Sie es nochmals.


von da an, konnte ich zwar ein Feld einfügen, ändern etc. Aber es speichert es irgendwie nicht.

Irgendeine andere Idee, an was es liegen könnte.
Was mir noch aufgefallen ist, dass die CRM Sessions ausserhalb des Ordners wo das CRM liegt gespeichert sind, hat das etwas damit zu tun?

Vielen Dank für neue Ideen.

Gruss
Claudia