Product image in PDF Template?

I am trying to insert the product image in the PDF Template. I insert the $aos_products_product_image filed into the line item cell, but when i generate the pdf it just shows a red X.
Is there some trick to get this working? Does the image have to reside in a certain folder?
In the products module when I add a product image it just shows a placeholder icon, with the image name.

Hi there,

What type is the image and what are its properties?



Hi Will
Can you show me on the Demo? I have tried both JPG and PNG files.
On the demo I tried it on a quote called PLACA TEST and used the QUOTE template. Same problem with a red X.



I had noticed this same problem on my installation and did have the time to pursue further. However, what I believe that it is a permissions issue with my apache server configuration on my vps.

In your browser,

  1. if you hover over the graphics link in question for the product definition and select “view image in another window” (note: exact syntax will vary depending on browser - I’m using chrome in this instance").

  2. See what error message you get. In my case I receive the following:


You don’t have permission to access /SuiteCRM/upload/Remote_desktop_connection_icon.png on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.[/spoiler]

In my case I if have painstaking set up the recursive permmissions correctly, but have not changed the group/owner of the root directory to what is specified. I’m going to try the same in the Demo to verify. Something to due with the upload directory. I’ve even tried setting png with 777 and still no luck.


Same Issue in the Demo. What are the exact specs for this image:

  1. JPG | PNG
  2. Size requirements ?

Hi guys,

This is actually a bug. This will be fixed in future releases.



HI Will
Do you have any idea on this bug? I was hoping it would be fixed in 7.02 but it is still there.
It is becoming an issue here as VTiger that i switched from did this perfectly.
please advise when you think it wold be fixed.

Do we have any update on when this will be fixed?
Will mentioned it was a bug that would be fixed. Please advise when we can expect a fix.
Needed urgently.


Another request.
Please advise.

It has been 7 months since Will said this would be addressed in the next release.
Please can we have some answer on this bug?

Any update on this bug?

Hi there,

The product image field/functionality is something we plan to address but is not something that has been fixed as yet. We’ll keep you updated on progress.



I just tested this again and added $aos_product_product_image to the PDF Quote template and this pulled up the image just fine (icon size - this can be fixed).

I still get the red X on my PDF.
What should the source of the image file be?
mine is

Doesn’t seem to matter if i use a PNG or JPG and what the size is.

Go to the mysql the database and see the contents of the following table: select aos_products.product_image from aos_products;

This will tell you how the product image is being stored. If it is taking the IP address of the server and constructing the URL, that is probably why it is failing.

To validate this, I change the IP Address of my server and all the images broke. Changed the IP back and all the images were back.

The right way to do this is to keep the path to the image relative, that way it will work all the time.

My images are all
This seems correct?
I use Xampp, so the structure is c:\xampp\htdocs\SuiteCRM\upload\

The path on your drive and the url have a different case. Does the graphic show up in the product details page on the site?

Hmm, you are on the right track. I don’t know how the case gets changed. I guess this is where the bug lies.
No, the image does not show up in the product details page, Just a Question Mark Icon.

So I edit the path for the image in Chrome,
I get a error.“Cannot connect to server”
If I edit the path to
Failed to load resource: the server responded with a status of 403 (Forbidden) which results in the question mark icon.

Found the issue. It is the .htaccess file under the suitecrm folder that is preventing access to the upload folder.

1 Like

Thank you Vishmehra.

I also find out that there was a .htaccess inside the upload folder that was blocking me.

I commented the second row…

Order Deny,Allow
#	Deny from all


it would be nice to have a feature that shows all images in List View