Problems with the theme

I installed the system, everything is brand new! But there is a problem in the template and I do not know how to solve. Already I tried to switch to the “Suite R” and then to “Suite 7” but still all the same. The top menu covers more than half of the screen!

I’ve tried to access through different browsers and the problem appeared in all of them.

Your CSS files aren’t getting loaded.

  • Did you do a “Quick repair and rebuild” after changing theme?

  • First try different browsers and clearing your browser cache to see if that solves the problem.

  • check permissions on your server (there are many pages online explaining how to do this for SuiteCRM)

Hello,

I’m having the same issue than pgr, therefore I’ve tried the following

  • Use the repair and rebuild feature = the feature is not available because the menus cover the screen

  • Close the browser, clear cache, use another browser = didn’t solved (using firefox and chrome)
  • Set permissions: 755 for the root suitecrm directory (where all the files are located) and 775 for all the internal files

Is there anything else I can do to avoid having the menus covering almost all the screen?

Thanks!

There is also a permissions diagnostic in Admin / Upgrade Wizard / press “Next” once. (Don’t worry, these first steps don’t upgrade anything). SuiteCRM will show you every single file with wrong permissions. My guess is style.css will be part of that list.

1 Like

Hi PGR

Thanks for the reply! I’m following your guidelines and this is what I’m getting

It seems that my installation has all the required permissions available (check it twice)

Then I made sure that the default theme was changed

Then I went to: Admin> Repair>Quick Repair and Rebuild and completed the process

Then I cleared the cache, logged out and login again and the issue remains… any other suggestion mate?

Many Thanks!

After logging in to SuiteCRM, try putting this into your browser’s address bar to load the css file directly:

http://your.address.com/themes/SuiteR/css/style.css

(replace your.address.com with your actual address of course)

You should see a long text file with CSS definitions. Hit CTRL-F5 on the browser a few times to force refresh if it doesn’t appear.

Then tell us what happened.

Note: if your browser is still in “View / Page Style / No Style” you need to change it back to “View / Page Style / Basic Page Style”

Hi PGR,

I followed your guidelines and my browser only showed a 404 error page, I tried refreshing many times, but wasn’t able to show the CSS definitions you mention…
What does it means? What can I do now?

Thanks!

Just to make sure, go to the root of your SuiteCRM installation and do
ls -al themes/SuiteR/css/style.css

to check is that file even exists on your SuiteCRM installation. Note the group and user ownership of the file, and the permissions.

If the permissions aren’t right, as i believe, set permissions correctly, following the steps on the link I gave above.

I don’t know why the permissions diagnostic says you don’t have a problem with permissions, but you clearly do, since your web server is not able to serve the file. That’s why the screens aren’t showing correctly. It seems the diagnostics are misleading.

You must know under which user and group your web server is running, in order to do the correct chown command.

At least make sure the permissions for that file get corrected and see if you can now load the file from the browser.

Hello PGR,

I found the css file within the files of the SuiteCRM root folder, the permission was 664 and I changed it to 775.
I think the last time I tried, I entered you provided URL incorrectly because then I realized that I forgot to add the correct name of the suiteCRM root folder to the whole URL. Therefore, the system check my not be completely wrong after all…

That being said, I was able to visualize the style.css file with the browser (firefox), which I guess it the whole css code just in plain text. If yes, what should I do with that or what should I look for (I atached a copy of the text that appeared after reaching the aforementioned URL)

In regard to the chown command, I have to say that I’m not completely sure about how to execute it. Nevertheless. I’ve talked with my hosting provider and they told me that I have to use SHH to do so… could you confirm that?

Thanks!

Hi

if you can see the file from your browser, you can forget permissions, they’re working… at least for that file. Maybe there are problems with others.

Anyway you really need to learn this to work with SuiteCRM. Try the SSH. Find out which user and group your web server runs under (ask your hosting providers, or figure it out with “ls -al” from the SSH shell).

Then from your SuiteCRM root folder:
sudo chown -R user:group .
sudo chmod -R 755 .
sudo chmod -R 775 cache custom modules themes data upload config_override.php

Your problem might not be permissions at all. There are plenty of similar threads coming up now. Some people are suggesting to try a different PHP version…

Thanks for the tips and explanations! But none of them worked, unfortunately.

I deleted all files and cleaned up the database. I reinstalled all over again, and still nothing worked.

I give up.

Ok, I tried again.

Giving up was in my plans, but … why not try one last time?

I accessed through the Chrome and inspected the page, which showed 16 errors.

All of them showing 403 error.

The error was folder cache, with folders that were created after installation.

I changed the permission of all these new folders and subfolders and WOW! IT WORKED!

:whistle:

It’s strange because the commands I gave you above include a full recursive setting of permissions on the cache folder…

But anyway I’m glad it works now!

Hey fortipropaganda,

Could explain a bit more about how did you do to solve the 403 error? just changing the permission for each of those files manually through the file manager of your hosting? did you erased them? I just erased everything, set up permissions carefylly using file manager and re-install suiteCRM, BUT… its not working :S

These are my errors:

Btw, I downloaded putty and tried to access using the keys provided in the Godaddy’s hosting manager, but putty shows a message saying “Server refuse us access” (or something like that)… so now I’m running out of patience… :unsure:

I had this same issue. I was able to resolve it by going to the cache directory and running the following command.

chmod -R 755 .
1 Like