Problems with installation on shared webspace

Dear User,

I wanted to try suitecrm on my own shared webspace.
The installation procedure was successful and I also can use the software. Didn’t try all functions up to now but it seems that all is working except some messages appearing in some menus. It seems that all is functioning except this message

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/.sites/212/site689/web/suitecrm/include/Smarty/Smarty_Compiler.class.php on line 268

Does anyone know what this message is and what caused it?

Thank you for your time.

Hi there,

Where is the message displaying? SuiteCRM displays many warnings/notices/deprecated errors. We would advise setting display_errors=off or modifying your error settings so that these warnings/notices are not shown(these are different to FATAL errors, which you should rectify/resolve).



Dear Will,

Manly the messages appear in the Search section of the sites and in the user management page. But I was not looking at all pages right now.

How do you disable the deprecated messages exactly?

Thank you


Hi Stefan,

I am in the same situation. I use a shared host. It is not the preferred environment for suiteCRM / sugarCRM.
It needs quite some tweaking to have suiteCRM running (quite) well on a shared server. It depends on the host, how much tweaking.
No environment is exactly the same, so every host needs more or less tweaking. The biggest problem thereby is on a shared server, you can’t adjust the environment, so the only way is to inform the software about the environment. This can be done by tweaking some settings.

One of the settings I have put in my .htaccess in the root of the suiteCRM installation, is a setting to prevent all the error messages from showing up which prevents the software from running well.

Because you likely do not have access to the php.ini file, you must use the .htaccess file. The below value prevents the error messages. But the downside is you also lose track of all errors in the crm system because you shut them off. Therefore, I am now searching for another solution, which instructs suiteCRM to ignore all the errors, but still to register them. I seem to have found the solution, but still have to implement it and try it out. The new solution, should be better, because when the php version upgrades, the error value numbers also changes. The means it could be you also have to change your line in the htaccess file. The code I saw, works different and prevents you have to keep track of the error level changes.

Add this to your htaccess file in the root of the suiteCRM installation:

php_value error_reporting 30711
# This is the E_ALL value (32767) and the removing the E_STRICT (2048) and E_NOTICE (8) values