Problems installing 7.10.7 - some errors possibly file ownership related?

Any and all help/suggestions appreciated!

Late June I installed (7.10.6? I think) on a VPS to play with and make sure it was right for my needs. I used Softaculous to install and had no issues.

Then I upgraded to a dedicated server at my hosting company and tried to install 7.10.7 manually.

On my first attempt, I failed to change ownership of the files, and it worked, but I when I realized what I’d done I was worried it would cause issues later, so I uninstalled and started over.

Second attempt, followed instructions regarding ownership and permissions to a tee, install seemed to go well, but site gave 500 server error, and no logs existed to try to figure out what happened. I had installed to the domain root, so I think that was a mistake - “nobody” owning the root folder is probably what prevented logs from being written. (So how do you manage this when installing to domain root?)

So I tried Softaculous, which tried to install 7.10.7 - I got this error during install :

Required PHP extension not found : mysqli

Hosting support insists that the extension is installed correctly.

I’m using PHP 7.1.20 if that matters.

Support then tried to install it and said they got a different error (see screenshot, attached)

So support says they installed it on a “test environment”, then moved it to my server. They insist it’s a problem with SuiteCRM’s code, not my server. When I asked “If it’s the code, how did you get it installed on a test environment” they’re trying to say I must have made changes to the server setup, but I didn’t!

It looks like it’s working, but I have yet to get very deep into it.

I DID notice that it is showing the cpanel account name as the owner of all the files.

I wish I could tell you more about the dedicated server, but the hosting company doesn’t give me much info (“here’s your server - good luck”)… and Linux is not really my cup of tea (yet - I’ll get there.) If you need something and can tell me where to look, I’ll gladly provide it. I have Putty and WinSCP both working with root access.

What I’m wondering is - is it possible that the server configuration is such that I SHOULD leave the ownership as the cpanel account, rather than changing it to “nobody” ? (This seems to be the only way it works but I found nothing in documention or in forums about doing it this way - they all say to change ownership.)

I’d be eternally grateful for any suggestions or insights (including advice or recommendations on hosting companies.)


Support said they “were able to resolve this issue by adjusting the default requirements of the SuiteCRM package on this server, in order to make it work. It appears that this issue was related to the Softaculous package that SuiteCRM used”

They said they made changes in this file /var/softaculous/suitecrm/info.xml

so I guess it was a setup problem on my server making it not work well with Softaculous? I don’t know and don’t really care, as long as it works! Just sharing in case SuiteCRM has anything to do with Softaculous SuiteCRM installation packages - if so this info might be of use to someone.

BUT this still doesn’t explain the file ownership issue. I am moving forward with the cpanel account as the owner (rather than “nobody” per instructions) but this makes me nervous - can this cause trouble? If anyone has experienced this before, I would be delighted to learn what you know about this account ownership discrepancy.