Problem with Reports

Hi, I am trying to create a report and I have entered some conditions as parameters including date, last name, first name and id.

  1. to search a range of dates, I use the Date field twice (one greater than and one less than); this only works if I set both dates, if I wanted only dates greater than October 1 it doesn’t find anything;
  2. if I don’t fill also the other fields set as parameters (id, last name, first name) it doesn’t find anything.
    Is this how the Report works? Or do I make a mistake? I expected it to work like the filter of a module, where a search is made even only on the basis of a populated field.
    I tried to set the conditions in the Report creation, with AND and OR, but it doesn’t work. Any ideas please?

Are you in the lastest version?

A few months ago a bug was fixed that looked similar, problems in Reports that used two date conditions, you can try searching Github for it.

Yes, I’ve seen some other issues with the dates, but they seem to work for me, but they both need to be set, I was wondering if that was necessary or is there something I need to set. Also, whatever other parameters I add must be set to work and must reflect all the search criteria, I can’t leave anything blank.
My version of Suite is:
Version 7.10.20
Sugar Version 6.5.25 (Version 344)

Your version looks new enough.

I am not sure if what you describe is a limitation of Reports, it probably is. A workaround is to have several clones of the Report, some with all the conditions available to be filled, others without one of the parameters (so you can use it as an equivalent of leaving that parameter blank). Not nice, but might work.

If I understand correctly, you suggest creating multiple reports, each with the parameters I need, right?
Anyway, I have seen the query that is created, actually it is right. It behaves as if I were to write a SQL query, so it looks for example, for last name fields that are empty (if the last name field is not set). It’s not a bug, but definitely a limitation, if there was a way to leave out the search on those fields that are empty, that would be great, I don’t know if it’s expected and you have to set it somehow, or it has to be that way.


Any other way, I think would require changes in code.

In any case I think there is a problem with the dates, apart from the problems already found in other discussions, if I set the date as a parameter (putting the same date, once greater than and once less than), if the results are spread over multiple pages, the moment I change page, the filter set is no longer considered and also brings back dates out of range.
Is it a bug?

Possibly. Probably. I don’t know, I don’t even use Reports… :slight_smile: